Question Put in new ram and now when I boot my pc I get s black screen

Sep 24, 2022
10
0
10
0
I've tried to reseat the ram, reset/clear my cmos use one stick, use one stick in a different slot and even trying to use my old ram to see if the new ram was faulty and I still get a black screen, nothings working. I tried checking my gpu, cpu and everything else and all cords are properly connected and seated but I still get a black screen idk what to do ;-;.

My specs
Motherboard-Msi Z370 Gaming Carbon Pro AC Mini Itx
GPU-1060 6GB
CPU-I5-8400
Old Ram-Patriot 8GB 2x 4GB
New Ram-RipJaws 16gb 2x 8GB
 

boju

Titan
Ambassador
Did you press in ram properly? Example video of what i mean, from 1:15 and then pushes down more at 1:20. Dimm slot clips should click into the notches on both sides of ram.


You did turn off power supply and disconnect power cable and leave sit for a bit for power to drain before working on pc?
 
Sep 24, 2022
10
0
10
0
Did you press in ram properly? Example video of what i mean, from 1:15 and then pushes down more at 1:20. Dimm slot clips should click into the notches on both sides of ram.


You did turn off power supply and disconnect power cable and leave sit for a bit for power to drain before working on pc?
Yeah I made sure to turn off the PC fully and hold the power button after to clear the capacitors and the ram is in the slots correctly
 

boju

Titan
Ambassador
There any sign of power? Leds, fans etc?

If you removed video cable before working on it did you put it back to the correct port? Not motherboard video port?

There's not a lot that can go wrong simply installing ram so trying to think of simple things.
 
Sep 24, 2022
10
0
10
0
There any sign of power? Leds, fans etc?

If you removed video cable before working on it did you put it back to the correct port? Not motherboard video port?

There's not a lot that can go wrong simply installing ram so trying to think of simple things.
Theres power my motherboard shows issues with its light and its showing that its not detecting the ram, but I cant even load bios to fix it because I just get a black screen I have all the cables plugged in and everything
 
Sep 24, 2022
10
0
10
0
There any sign of power? Leds, fans etc?

If you removed video cable before working on it did you put it back to the correct port? Not motherboard video port?

There's not a lot that can go wrong simply installing ram so trying to think of simple things.
I just noticed my gpu fan starts and then stops spinning when I turn my pc on
 

boju

Titan
Ambassador
I know how to fix it from bios I just cant figure out how to get it to boot ;-;
How would you fix post failing in bios? There's not. It's hardware self check, if something isn't right the system stops powering up.

Debug led remains on ram. Now you say ram is fully seated, ok then, but have you done anything else? Reinstall cpu?. Bent pins if so. There's more to this situation you aren't saying, installing different set of ram doesn't, all of a sudden, cause problems like this.
 
Sep 24, 2022
10
0
10
0
How would you fix post failing in bios? There's not. It's hardware self check, if something isn't right the system stops powering up.

Debug led remains on ram. Now you say ram is fully seated, ok then, but have you done anything else? Reinstall cpu?. Bent pins if so. There's more to this situation you aren't saying, installing different set of ram doesn't, all of a sudden, cause problems like this.
Heres exactly what I did, I turned my pc off took my ram out and then put the new ram in and now its just not working I havent tried reinstalling the cpu yet I'll try that
 

ASK THE COMMUNITY

TRENDING THREADS