Question Puzzled with Corsair CX750M supplies working on some computers

Oct 10, 2019
1
0
10
0
Hi there!

So I started a new build the other day and bought a brand new Corsair CX750M for this build. Got it installed and it wouldn't power on. So I started rechecking everything, then I was able to get it to power up. So I started installing Windows 10. Install went fine, BUT when I got to the setup screen where you enter in the computer's name and create a password it would restart. Tried multiple times and could not get passed this point. So I started disconnecting drives, switching out memory, trying different hard drive and nothing worked. I kept getting the same problem. So I pulled apart my other PC which has a slightly older Corsair CX750M in it. Plugged that power supply into the new build and every worked fine. So I figured I had a defective PSU. Sent it back to Amazon and got another one. Went to install it today and I had the exact same problem with the new replacement Corsair CX750M.... SO I was completely perplexed.....

I ended up swapping the old build PSU with the brand new PSU and magically both machines are perfectly stable. I am completely stumped as to why the new Corsair CX750M won't work in the new build, and why for some reason my older Corsair CX750M will work in the new build.

Anyone else have this issue? Anyone have any idea as to why this is?
 

ASK THE COMMUNITY

TRENDING THREADS