Question Q-Led bios red regardless of what I do | B450 and B550 with Ryzen 5 3600

Apr 3, 2021
2
0
10
0
My first specs were:

CPU: Ryzen 5 3600
GPU: GTX 1660 TI Zotac Amp
Memory: 2x8Gb 3000Mhz Corsair Vengeance LPX
Mobo: B450 Pro Aorus mATX
Power Supply: CX550 Corsair
SSD: XPG SX6000Lite 1Tb

After 6 months of normal use (turning on in the morning and turning off at night), suddenly my PC wasn't turning on and the Red Light (CPU) appear on the "Q-LED" of Aorus (I can't remember how they called it).
After this, I tested my DRAMs and my GPU on a friend's PC just to check that these 2 parts are ok!
So, I've called an RMA to the mobo, and they have returned a brand new B450, the same model. And, just after put the parts together, the same problem, Q-Led with red light.

Now I took the PC to a computer store. They checked/tested all the parts and said that all the parts, except the motherboard, were good. So, I called another new RMA (second), a new mobo has arrives and the same happened again. At this moment I began to think that my CPU or my power supply is no longer working well, but I needed to trust the services of the computer store to proceed with a new RMA.

New RMA (third), a new mobo... and the same. Now I asked for the money back and bought the Asus Rog Strix B550-I Gaming (Mini ITX), to take the opportunity to switch from motherboards to mount a Mini ITX build.

And... same problem! BUT, this motherboard has the Asus Flashback where we can update the BIOS without turning on the computer (but needed a CPU in place), and one of my fear was that the BIOS of the B450 wasn't updated from the factory to work with the Ryzen 5 3600 after the first RMA. Well, I did update to the newest version and to the oldest, reading the "patch notes" and updating and turning on to see if this can make the difference, but nothing happened at all. Always ended with Q-Led on red.

At this moment I tried all you can imagine, but these posts synthesize what I did:
Now I think:
  • Is the CPU really fine? How can I test it without a new Mobo (again...)?
    • Maybe I can call an RMA to the CPU
  • And the Power Supply: Can this be the problem in this situation?
  • Or I'm just an unlucky guy? I've built so many PCs in my life and now this. I'm very tired of all this.
Thanks for all!
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

The chipset heating doesn't do anything. You might've seen videos that were released on April Fool's Day, not joking, that hair dryer stunt is pointless.

If you want to rule out your CPU being the culprit, take the processor and drop it into a known working motherboard that can accept the processor(i.e, it has the necessary BIOS version). I'd advise on also taking your ram kit to work in tandem with the processor. Use one stick of ram, first.

You do need to borrow a higher quality and wattage PSU for your build, from your neighbor or friend in order to rule out your PSU being the fault.

Yes it could be possible that the board lacked the BIOS update from the factory but in order to verify that, you can find a long sticker that has a 4 digit number at the end, that's the BIOS version the board came with in the box.
 
Reactions: DougRoluds
Apr 3, 2021
2
0
10
0
Thanks, Lutfij :LOL:!

> The chipset heating doesn't do anything. You might've seen videos that were released on April Fool's Day, not joking, that hair dryer stunt is pointless.

I did this much before April Fool's day. The videos are unrelated to this. I'm from Brazil and for some reason, had many videos about this "temporary solution" in here. Well, I tried! LoL.

Unfortunately, all the ways to solve this are having parts where I know that is working, but, none of my friends have a computer like this, only notebooks (and the pandemic here is no joking with us to find anyone that can help me with this). Maybe I need to take all the parts again to the computer store and believe in what they say.

Where I live, having a computer is a luxury.
 

ASK THE COMMUNITY