Q8300 + nforce 630i issue


Jan 28, 2009
I recently bought an Q8300 cpu & four month before i bought a nforce 630i chipset motherboard from xfx...on xfx website & nvidia website it clearly says that this motherboard can support all Quadcore series LGA 775 from intel but my Q8300 dosnt runs on it...when i install Q8300 and run the system the RED (HDD LED) kept glowing & system do not boots & i cannot even go to BIOS setup...i also tried by disconnecting the hard drive but still it do not boots it just hangs up * red led kept glowing and i cannot even go to BIOS...it also not shows the system specifications at the start....but when i run my 4 year old pentium 4 on the same board it runs fine...so i thought Q8300 is damaged... so i went to return it to the shop but when they tested the Q8300 on intel chipset boards it was working fine...I cannot understand why my board cannot run the Q8300 even though it supports all core 2 Quad series...should i get a new intel board???
Check the bios version of your xfx board at the top of the post screen. Use the "pause" key and write it down. Then email xfx or check their website for recommended cpus and see if a bios flash is needed.
nVidia originally said that the 680i boards would support Yorkfield CPU's. This was based on preproduction samples. Then nVidia and Intel got into a p*ssing contest, and when production CPU's arrived, the 680i chipsets did not support Yorkfield. I do not know where the 630i's come in, but I suspect that's true for them also.

Your experience seems to bear that out. You might try to update the BIOS with your old chip, then try the Q8300 again.