Question QNAP TS-832X NAS and Windows 10 PC: Error 0x8007003B: An unexpected network error occurred

Aug 16, 2019
6
0
10
0
Hi!

A month ago I received a new QNAP TS-832X, which I installed with four 8 TB Seagate Barracuda drives in RAID 5 configuration. Starting the process of copying files from my Windows 10 computer, I received the following error after a few thousand files:

Error 0x8007003B: An unexpected network error occurred.

At first I thought it was something related to my network, cards, cables, etc, so I've spent several weeks now trying out a lot of different configurations, changing my computer hardware, software settings etc, but the error is haunting me like a ghost.

My configuration:

NAS:
  • QNAP TS-832X running the newest firmware 4.4.1.0998
  • 4x8TB Seagate Barracuda ST8000DM004 drives, all brand new
  • ASUS Hyper x4 PCI card with Samsung 960 EVO 500 GB M.2 SSD as cache
  • Samsung 850 EVO 500 GB SATA SSD, for testing a different drive as storage drive and cache drive
  • QNAP QXG-10G1T, for testing a different network setup
Computer:
  • ASUS ROG Z370-F mainboard on newest BIOS, rev. 2401
  • Intel i7-8700k CPU (now upgraded to i9-9900K)
  • 32 GB 3200 MHz RAM
  • Samsung 960 EVO M.2 500 GB SSD as boot drive (now upgraded to EVO 970 M.2 1 TB)
  • 2x2 TB intel 660p M.2 SSD drives in RAID 0 on an ASUS Hyper x16 as project drive
  • 2x8 TB Seagate Ironwolf data drives
  • 4x10 TB WD EMAZ ("white label" WD RED) drives in RAID 5 for storage
  • nVidia GTX 1070
  • HP NC552SFP 10Gb 2-port SFP+ ethernet server adapter, upgraded to newest BIOS
  • ASUS XG-C100C RJ45 10Gb network adapter for testing a different network setup
  • Running Windows 10 Pro English
What I've tried to fix the error:
  • - Tried a large number of different network setups and tested six different cables, including:
  • - Two different SFP+ direct connect cables from built-in port in QNAP NAS to HP NC552 on the PC
  • - Cat 6 and Cat 7 cables directly connected from QNAP 10 GbE card in NAS x2 PCI slot to my PC with ASUS 10 GbE adapter
  • - Cat 5, 6 and 7 cables from QNAP gigabit port via gigabit switch to built-in gigabit port in my PC
  • - Tried both SFP+ ports on both my computer and both ports on the QNAP NAS
  • - Tried with fixed IP in different IP ranges (192.x, 10.0.x)
  • - Tried with DHCP where both computer and NAS resolves their IP addresses
All cables and network cards bought brand new.

A lot of different tips and solutions shows up when googling or searching forums, so I've also tried:
  • Disabled Windows Antivirus
  • Disabled Windows Firewall
  • Disabled Windows Search Service
  • Enabled and disabled Jumbo frames
  • Setting both minimum and maximum SMB version = 3.0.
More hardware-related, I've tried:
  • Removing the M.2 cache and the ASUS Hyper card, and run the four drives on the NAS without cache
  • Using SATA SSD as NAS cache instead
  • Using SATA SSD as storage drive on my NAS, copying data to/from this drive instead of the RAID array
  • Copying to/from different drives on the PC
  • Upgrading BIOS on my mainboard and network card to the latest versions
In sheer desperation, in case my Windows installation was corrupted, I've also tried:
  • Installing new CPU and M.2 boot drive to my computer
  • Clean install of Windows 10 Pro
But nothing I've tried, seem to work. The error occurs on irregular intervals, and file size don't seem to affect the error. (Ref a lot of people with problems on 100 MB+ files).
I can copy files 15 GB in size, often without error, sometimes I can copy hundreds of gigabytes and thousands of files, sometimes for an hour or more, but eventually, the errror will interrupt file copying.

As you can imagine, I've never been able to complete a full backup from my PC.

When the error occurs, I can press "Retry" and file copying continues for a while, until the same error comes back.

The file that was about to be copied just as the error occured, will NOT be copied when I press retry! Instead, a file 0 bytes in size is created on the NAS, and it then continues on the next file. So when copying a huge number of files, I'll end up with many 0 size files, one per error, which can be quite a few.

Hope that someone can help me with this issue, which makes my new QNAP NAS practically useless..

Kind regards,
- Jørn
 
Aug 16, 2019
6
0
10
0
popatim: that is a possible cause, so I also tested using a single 500 GB SATA SSD as data volume in the NAS and still received the same errors, which makes me think the error resides elsewhere...
 

ASK THE COMMUNITY

TRENDING THREADS