Question Quadro K2200 issue

Jul 19, 2020
8
1
15
0
I am using an Asus Prime x570-P MoBoard with a AMD Ryzen 7 3700X CPU and 16GB Corsair Vengeance 3200 ram. The GPU is an Nvidia Quadro K2200 which has 4 GB ram built in.
I am having some problems with sluggish photo rendering (the principle use of my PC) which has prompted me to investigate my system. I AM NOT A TECHIE and think over clocking is being late for work!
I have noticed that the GPU RAM is hardly being used at all (using task manager). Further investigation shows Device manager is detecting the GPU but in looking into the BIOS (that took courage) I can see no sign of the GPU. It is obviously working to some degree as I have 2 monitors connected to the GPU and the NVIDIA desktop app controls both.
Now the question: Where should I find evidence in the BIOS that the GPU is being detected (various forums suggest it should be visible in the BIOS but do not say where EXACTLY to find it!) and depending on that answer what should I be doing to ensure the GPU is earning its money as it was an expensive investment? I have downloaded the latest Drivers for the GPU and updated the BIOS to the latest version.
 

faalin

Judicious
you wont find you GPU in the bios. once in windows click the start button and type Device Manager, next to display adapters click the little arrow and it will display your GPU.

As for sluggish what programs are you running? Are you sure they are setup to run off the GPU and not CPU render?
 
Jul 19, 2020
8
1
15
0
I use Adobe photo suite which includes a RAW file processor called Bridge. It claims to use GPU acceleration and is detected by the program as it is displayed in the "preferences" section. The GPU does show in "device manager".
 

faalin

Judicious
reading this Adobe help you might need to enable the GPU in adobe to fully use it.

How do I use the Performance preferences for the graphics processor in Photoshop?


    • Choose Edit > Preferences > Performance (Windows®) or Photoshop > Preferences > Performance (macOS).

    • In the Performance panel, make sure that Use Graphics Processor is selected in the Graphics Processor Settings section.

    • Click Advanced Settings and specify the following options:
      Drawing Mode:
      • Basic: Uses the least amount of graphics card memory (VRAM) and enables basic graphics processor features
      • Normal: Uses more graphics card memory (VRAM) and enables graphics processor-based color matching, tone mapping, and checkerboard blending
      • Advanced: Provides the benefits of Normal mode and newer graphics processor advances that can result in improved performance
      Use Graphics Processor to Accelerate Computation: Enable to improve the interactivity of Warp and Puppet Warp previews
      Use OpenCL: Enable to accelerate the new Blur Gallery filters, Smart Sharpen, Select Focus Area, or Image Size with Preserve Details selected (Note: OpenCL is available only on newer graphics cards that support OpenCL v1.1 or later.)
      Anti-alias Guides and Paths: Allows the graphics processor to smooth the edges of drawn guides and paths
      30-bit Display (Windows® only): Allows Photoshop to display 30-bit data directly to screen on video cards that support it
 
Jul 19, 2020
8
1
15
0
Further reply. Changed Drawing mode to advanced but only slight improvement. Still far from perfect. Beginning to think it is an Adobe issue as rendering the same file in other versions is silky smooth!
The GPU barely gets out of bed! If I open all three Adobe rendering apps (Br, LR & PS) I can force the usage to get up to about 30% but obviously that is not a practical use of the system. Every measure tells me that everything is working to spec except my eyes!
 

ASK THE COMMUNITY

TRENDING THREADS