Question Question about Asus Ryujin II 360

Sep 4, 2022
5
0
10
0
Hi guys, I just received a new cooler. The last one got pump issues after 4 months. So I installed this one with extra caution. but still got a few problems to ask.

Motherboard: MSI MPG Z690 EDGE WIFI DDR4
CPU: Intel® Core™ i9-12900K

1) As we know You can not change pump/fan speed in BIOS. Asus make us use Armoury Crate for it. So I wanna adjust my Pump Speed to 2800 RPM. Even Armoury Crate shows I already change it to 2800. But the cooler screen still shows 1680~1740. Is there a way to change it or is it just a software bug?

2) My cooler got some serious plastic kind smell after I turn on my PC. Is that normal?

3) After I change my Pump RPM to 2800( Even the screen said is 1680~1710) I got a buzzing noise coming from my header. It decreases if I lower my Pump RPM . Is that normal or should I return it again?

Thanks for your help.

Buzzing noise Video: https://youtube.com/shorts/QZZgqQAZ2PU?feature=share

Armoury Crate: https://www.pinterest.ca/pin/703828248031762162
 
Last edited:
Sep 4, 2022
5
0
10
0
Welcome to the forums, newcomer!

What is the make and model of your case and how is the cooler oriented in said case?
Hello, Thanks for the quick reply. My Cooler is set on the top of my case and my Case is Lian li o11 dynamic Evo
 

Lutfij

Titan
Moderator
Use the uninstaller for the app listed under Asus's support site, here, then manually reinstall Armory crate in an elevated command, i.e, Right click installer>Run as Administrator. What BIOS version are you on for your motherboard?
 
Last edited:
Sep 4, 2022
5
0
10
0
Use the uninstaller for the app listed under Asus's support site, here, then manually reinstall Armory crate in an elevated command, i.e, Right click installer>Run as Administrator. What BIOS version are you on for your motherboard?
My BIOS should be 1.70. Uninstall Armory Crate NOW
 
Sep 4, 2022
5
0
10
0
Use the uninstaller for the app listed under Asus's support site, here, then manually reinstall Armory crate in an elevated command, i.e, Right click installer>Run as Administrator. What BIOS version are you on for your motherboard?
Correction: My BIOS should be E7D311MS.170
 
Sep 4, 2022
5
0
10
0
Use the uninstaller for the app listed under Asus's support site, here, then manually reinstall Armory crate in an elevated command, i.e, Right click installer>Run as Administrator. What BIOS version are you on for your motherboard?
Hi there So I update my BIOS and reinstall the Crate. It is still the same. It won't let me change the Pumo RPM to 2800
 

Karadjgne

Titan
Ambassador
The pump responds before asus does. It takes @ 5-6 seconds for the aio pump reading to respond to changes. I've got zero issues in Armory putting my pump anywhere from 1100rpm to 4500rpm and hit apply. I can hear the pump difference, 5-6 seconds before the Armory reads the change in the bottom right box of fan eXpert 4.
As we know You can not change pump/fan speed in BIOS. Asus make us use Armoury Crate for it.
Not true. The Ryujin II uses a header connection for pump speeds, should normally be on AIO_Pump header and set for 100%. If you hooked up that connection wrong, or if the header isn't set for 100%, it can read wrong. All it takes is you being off 1x pin and that read wire being on pwm instead of rpm, and you'll get a % signal instead of a read sent to the pump.
 
Last edited:

ASK THE COMMUNITY