[SOLVED] R9 290x latest driver cause black screen in every game

Metalrocks

Honorable
Nov 13, 2014
179
1
10,685
0
I have installed the latest drivers (adrenalin 2020 edition 20.1.3) for my mentioned GPU and the installation went without any issues. However, every game I have tried from old to new, the screen is constantly black and maybe a quick glimpse of the game can be seen. The games do run and I can hear the sound of the game. With some I can play for a bit before the screen turns black again. At times only for a short moment but still aggravating when it happens.
I had to delete and install the older drivers but looks like to no avail. Even with the old, working drivers the screen turns black.
In win itself, no issues whatsoever. I have win 7 64 bit and yes, I have installed the correct ones.

Any idea what the cause could be?
 
Last edited:

EphyMusic

Commendable
May 4, 2017
29
1
1,545
3
Might I suggest doing a quick reseat of your GPU? And check the profiles in the new 2020 edition. By default I think it is set to some general purpose option.

Otherwise, use the AMD Clean Up Utility located in your AMD install (typically C:\AMD\Win7-64Bit-Radeon-Software(differs here depending on software)\Bin64). It'll restart your computer into Safe Mode (on win10, not sure what it does on Win7 these days) and begin to purge the drivers. After it's done and you restart back into Not-So-Safe-But-Still-Relatively-Safe-I-Guess Mode, resintall the drivers.
 

EphyMusic

Commendable
May 4, 2017
29
1
1,545
3
Might I suggest doing a quick reseat of your GPU? And check the profiles in the new 2020 edition. By default I think it is set to some general purpose option.

Otherwise, use the AMD Clean Up Utility located in your AMD install (typically C:\AMD\Win7-64Bit-Radeon-Software(differs here depending on software)\Bin64). It'll restart your computer into Safe Mode (on win10, not sure what it does on Win7 these days) and begin to purge the drivers. After it's done and you restart back into Not-So-Safe-But-Still-Relatively-Safe-I-Guess Mode, resintall the drivers.
 

Metalrocks

Honorable
Nov 13, 2014
179
1
10,685
0
Dodgy installation? Uninstall and go back to the previous driver. Do you have a restore point?
Thanks. Done all of that. I uninstalled the driver before I installed the new one. The same I did when switching back to the older one I know worked.

Might I suggest doing a quick reseat of your GPU? And check the profiles in the new 2020 edition. By default I think it is set to some general purpose option.

Otherwise, use the AMD Clean Up Utility located in your AMD install (typically C:\AMD\Win7-64Bit-Radeon-Software(differs here depending on software)\Bin64). It'll restart your computer into Safe Mode (on win10, not sure what it does on Win7 these days) and begin to purge the drivers. After it's done and you restart back into Not-So-Safe-But-Still-Relatively-Safe-I-Guess Mode, resintall the drivers.
Havn't tried with safe mode. Strange nevertheless why with a previously working driver, it wont work anymore. May give it a try.
 

Kristomani

Prominent
Dec 12, 2019
60
4
535
0
I got similar problem on my R9 290X Lighting. I play Skyrim and Fallout, everything loads fine, but after 10 sec into load save I get lots of strange symbols, looking like 'manly parts' on lower screen, then upper and lower, screen goes black, a little empty black window up in left corner, then game comes back again. Goes on like this for about a min, then crash to desktop. My gpu is probably on the dying path...
 

ASK THE COMMUNITY

TRENDING THREADS