Question R9 380x Nitro no sound through T.V.

silversmithy

Distinguished
Nov 13, 2012
257
4
18,785
0
First of all sorry if this is in the wrong area.
So I have been putting together an old Z440 workstation and did eventually get the right software to reinstall Windows 7 pro. I installed an R9 380x a little bit ago and had installed the drivers to a thumb drive elsewhere as where I live currently the connection is very slow. When installing drivers at one point an error msg came up stating certain drivers were not digitally signed, and we're not installed. It never gave me the option to allow.
I never thought much about it as the quick test of the card seemed good, and in device manager it shows up as working properly. I never thought to test audio...until today.
I added some ram to the machine today and while testing it out, noticed that sound is only coming from the front pc speaker only, and when I look under playback devices only speakers are available, T.V. does not. When I scroll through device manager I see that there is the little dreaded yellow question mark by the AMD high definition audio, and states drivers not digitally signed.
The HDMI through the T.V speakers works fine with other computers and an old ps3.
Any help/advice would really be appreciated. Thanks
 

boju

Titan
Ambassador
Last edited:
Reactions: silversmithy

silversmithy

Distinguished
Nov 13, 2012
257
4
18,785
0
One thing also I was wondering about. If I were to disable driver signature enforcement at startup (hitting f8 I guess) will the previously unsigned drivers automatically be recognized, and installed or do I need to reinstall the whole pack again? Also on AMD's site there is a WHQL driver that is just slightly older than the most recent version which I am pretty sure I installed the first time. Will it hurt to download that driver to a thumb drive and go ahead and install right over what is already there? The issue with DDU is that my internet connection is so slow that many times downloads that use to take 20 minutes or less take hours, and sometimes will not even ever fully download. Thanks again.
 

silversmithy

Distinguished
Nov 13, 2012
257
4
18,785
0
Just tried disabling driver signature enforcement and the TV was immediately detected and audio working. Not sure if I will have to do this step every time I start...
 

ASK THE COMMUNITY

TRENDING THREADS