Radeon 7770 Resolution Problem

Mike MPD

Honorable
Jun 22, 2012
12
0
10,510
So i received and installed the 7770 today. only problem I've run into so far is that the largest resolution I can set the card to (catalyst settings) is 1680x1050. My native resolution is 1920x1080, when I try and set my resolution back to 1920x1080(windows settings) I get a black space all around my screen.

Any solutions?
 

oxford373

Distinguished
Jun 22, 2009
618
0
19,060
did you set refresh rate at 60HZ
did you uninstall your last drivers before you inserted your new gfx
it will be much easier if you can try 7770 on other PC to know what is the problem exactly
try the latest drivers
 

Mike MPD

Honorable
Jun 22, 2012
12
0
10,510
Refresh rate is at 60HZ, I did uninstall the last drivers, and I do have the latest drivers for the current card and monitor.

I will try the monitor on another comp...
 

cyberkash40

Honorable
Jan 26, 2013
1
0
10,510
I had the same problem and I have just solved it. I'm a spanish user so maybe the translation for the buttons I pushed it's not so accurate, but hey, give it a try. In your AMD VISION Engine Control Center go to "My Digital Panels" (i guess) and then to "Scaling Option"... I dunno if that's the best translation. Anyway it should show you a percentage bar with the "Infraexploration" or "Overexploration" percentage you're using. Just set it back to 0% and that solves it!

Good Luck!
 

codemonkey82

Honorable
Jan 31, 2013
1
0
10,510
Thanks so much cyberkash40!!! This resolved the problem, I found that after installing the AMD Vision Engine Control Center the default for the Scaling Option was almost 10% and not 0%. I have not idea why they did this and this setting over rides the Windows Screen Resolution settings.

Steps you provided were spot on!

1. Open 'AMD Vision Engine Control Center
2. Select -> 'Scaling Options' (Under 'My Digital Flat Panels' Tab)
3. Change 'Scaling Option' slider to 'Overscan' (0%)

This should scale out and allow you to utilize all of the screen real estate (1920x1080)