Radeon HD5670


Mar 20, 2012
I have a Radeon HD5670 installed currently, and when it works, it works perfectly. Havnt had an issue out of it playing Skyrim, Swtor, or SC2.
My issue comes at boot. 85% of the time It wont display post. And it doesnt suddenly work when windows boots the drivers either. if I wait long enough, I can hear the windows start music, but still no video.
After about 30 restarts or so, itll suddenly boot up like there was never an issue.
My best option currently seems to be to leave my computer on indefinately... but if I have to restart for updates or anything, it sucks lol.

When I first got the card off a friends upgrade, I tested it in a few computers and had no luck getting it to boot. Only when I got a new computer without onboard did I really test it and figure out it Would boot, but only if it wants to.


Apr 2, 2012
I have the same problem. I have been using the card with this issue for a while now but I can't work out what the problem is. It seems to run fine and then every now and again it has its moment and only allows me to boot off of the on-board graphics. I thought it was my power supply to begin with because I had a cheap one, but then I upgraded it and had the same problems.

I have updated my BIOS(Motherboard) and checked to see if the card is seated properly many times. I've tried updating the driver for the graphics card but ATIs catalyst centre tells it me is up-to-date.

I have tested the card in some of my mate's computers and it has booted fine every time. The only conclusion we got to at this stage was that 'it's dusty' and admittedly it was so we gave it a clean and it booted. But that didn't stop the issue arising again a few days later.

I'm not sure if this issue relates to the card and the mobo not working together well or what so I'll post my specs to begin with. It would be greatly appreciated if anyone could lend a thought and possibly point us in the right direction. Also, if you know of another place to get drivers from other than ATI that would help, as I can't say I trust all the sites I've seen them on.



Motherboard: ASUS M4A78LT-M LE
Memory: Corsair XMS3 2x4GB 1600Mhz 1.65v (This is a recent upgrade but I still had the issue before)
PSU: Corsair 430w v2
CPU: AMD Athlon x4 630
Standard HDD

Similar threads