Radeon R9 290 self-installs drivers (Win10), then gets a black screen

Justiceinacan

Reputable
Jul 19, 2016
2,034
0
4,660
444
Hello everyone.

I'm trying to get this Radeon R9 290 I have to work on Windows (fresh install of 10 pro 64-bit). Basically, I tried installing drivers, now I get a black screen after doing just about anything, and it lingers for a very long time (20+ minutes, just shut off my PC after that) Funny thing is, the drivers were downloading in chrome, yet my screen went to a proper resolution and device manager read "Radeon R9 200 series" before it went dark. Restarting grants you about 5 seconds of freedom before it goes black again.

I did some searching and I found out you can block windows from automatically setting up devices. So I did that, and tried downloading drivers only to have the same issue ; midway through the download they just install themselves then the screen goes dark soon after. Third time setting up Windows 10 and I notice, before my internet connection is even on "Searching for Display Driver". Presumably, that keeps going after I turn on my internet connection. How can I tell Windows to stop and let me find the right one myself, because whatever it is installing doesn't seem to be working properly?

Thanks in advance.
 

Justiceinacan

Reputable
Jul 19, 2016
2,034
0
4,660
444
Upgrading existing setup from busted GTX 760. My brother told me to just do a fresh install of Windows while I was at it.

i5 2500k, ASUS P8768-V-PRO, 16 GB 1600MHz, XFX XTR 650W. Rolled back the OC, works fine with my testing GTX 460, but no luck on the R9 290.
 

Justiceinacan

Reputable
Jul 19, 2016
2,034
0
4,660
444
So I resolved the problem (I think) by doing this.

Reinstalled windows again, so we're on AMD's "ATOMBIOS" for display. Ethernet unplugged, USB with Crimson 16.12.2 on it. Install those drivers and reboot - note that windows doesn't notify you that they're looking for display drivers, because you have them now.

I still got a black screen with chrome, from past experience disabling hardware acceleration helps. It's in settings > advanced settings under "system".
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts