Question Rainbow Six Siege Low FPS

Dec 18, 2020
19
2
15
0
Hi! So I built this PC around a month and a half ago, but I've decided to ask this question now (asked on a previous post but no one ended up responding after they asked me a question). On the first day of this pc being built, I was at a constant 144 fps with the highest settings, in menu and in game. No drops. However, on the second day, it had dropped to around 90-70 fps in game and like around 70-80 in the menu screens, and it has been like that since. When I got on to R6 a couple of days ago, there was this update, but after that update, I was now at 100 fps in game and 144 fps in the menu? I can't tell if the FPS increase in the menus was because of the new background though. Should I do a bios check or reinstall drivers? You should also know that I have GeForce Experience but I disabled the in-game overlay. I am currently on driver version 461.40. I'm quite confused and a little bummed out that my PC isn't performing as well as it should be. If anyone could help me out I'd appreciate it a lot. Thanks!

I also should mention that on the first day I think I was getting 144 FPS on Overwatch on ultra settings, but wasn't on the second day, so I do suspect that it might be something wrong with the whole pc, not just rainbow, however, it could just be something wrong with just rainbow.
CPU: I7 9700k
GPU: RTX 3060 TI Founders Edition
RAM; 16GB corsair vengeance ram 3200 (overclocked to 3200)
PSU: Corsair RMx 650 Gold
Motherboard: MSI z390-a pro
CPU cooler: Noctua NH-U12s
Monitor: 1920 x 1080p
 
Dec 18, 2020
19
2
15
0
I feel that it might be something wrong with my whole pc and not just rainbow considering that my overwatch fps dropped a little as well if I do remember correctly, any ideas?
 

ASK THE COMMUNITY

TRENDING THREADS