Rainbow Six Siege Stream Lag


Aug 18, 2015
Using Streamlabs OBS, have tried streaming Rainbow Six Siege past days and my stream always drops frames. The stream drops frames hard, audio stays smooth and the in-game FPS is completely fine. The only fix I have found is using 2 frame V-Sync in game which halves my FPS in game and stops the stream frame drops, the problem with this is that 70fps on a 144hz is not really enjoyable at all, especially on tryhard ranked. I have tried the other V-Sync options and they do not work. The CPU reaches 100% load on both settings whether it be 140fps or 70fps.


i7 8700k OC'd @ 4.8GHz
Gigabyte GTX 1080
16GB DDR4 3200


6000 Bitrate
Encoding with CPU but have also tried NVENC as a fix but to no avail

Any ideas?


your issue lies in CPU usage.

By default, OBS uses some of your CPU just to run.
Then, it uses more and more CPU depending on how many things you add to a scene as well as their individual complexity/size of the file. Adding browser extensions taxes the CPU quite a bit per extension (i.e. notification gifs from streamlabs for new followers and such)

Further more, it then uses a substantial amount of CPU to encode the scene into a stream.
Lower your graphic settings to the point where you aren't using much CPU, preferably less than 50% somewhere around 30-40%.

Then, in OBS, change your stream bitrate to 1500, then change the base resolution to 720p and the output to 720p, and keep the scaling to bilinear and the fps at 30.

Next, make sure to remove anything from your scene leaving only the game and the webcam (if you use one) and see how it fares.

If it looks like your CPU has some wiggle room, you can then start to add little things here and there such as a simplistic overlay and such one at a time and continue to run tests to see how it does.

Don't stream for your testing, just make sure the recording settings are set to use the streaming settings and hit record then playback that recording using something like VLC media player to see any stuttering, frame drops, skips, etc.

If wanting to use the NVENC encoder instead, keep the quality setting at default and make sure you turn down graphic settings to a point where there's not a huge load on your GPU allowing a little room for the NVENC to do it's thing without issue and for you to maintain higher frame rates.