Question RAM B2 Slot broken/not working

Jul 26, 2019
7
0
10
0
Hello gaymers,
I've been experiencing several weird issues with my RAM. When I only have one RAM stick in at a time (in the A2 slot) it works fine- it successfully overclocks to 3000MHz and windows recognises that it is installed. However as soon as I put another stick of RAM in (in the B2 slot), when I power on my desktop, it fails to boot 3 times. What I mean by this is that the LEDs light up and the fans start whirring, but then suddenly turn off and on again 3 times. Then when I open up task manager, although it says I have 16GB successfully installed, it says it is reserving a whopping 8GB for hardware i.e. all the memory I just added. Also, in CPU-Z and task manager, the RAM speed is knocked down from 3000MHz to 2133MHz (it's default speed and overclocking will not work.)

If anyone has had a similar problem to this, is it fixable or should I just get a replacement? Also is it possible that this would cause black screens? I've been getting a lot when playing visually-demanding games Sekiro (about one every hour maybe) and I can't play Battlefield V multiplayer because it will black screen in 5 minutes. Occasionally I will also get blue screens in which the error is "Thread stuck in device driver" and updating all my drivers has not helped.

Thank you for any suggestions my fellow gaymers. :)

RAM: Corsair Vengeance CMK16GX4M2D3000C16
CPU: Ryzen 5 2600
GPU: Radeon RX Vega 56
Mobo: ASRock B450M Pro4-f
PSU: Corsair VS650
OS: Windows 10
 

ASK THE COMMUNITY

TRENDING THREADS