Question Ram is 2666Mhz but only comes up as 1066Mhz

MKLninja

Commendable
Mar 17, 2019
218
6
1,595
2
So I checked Task manager and it says my speed is 1067Mhz. I checked on CPUID CPU-Z as well and it says the same thing, is this normal or is my ram not using all of its speed?

https://ibb.co/PgX53kx - Link to photo of task and CPUID

I have Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 2666MHz (PC4-21300) C16 Memory Kit - Black

Any help would be nice, thank you!
 

keith12

Illustrious
Hey there,

So, 1066 actually = 2133mhz. The ram is DDR (Double data rate) so you multiply 1066 x 2 = 2133mhz effective speed.

Pleas list your PC specs. So we can tell what mobo you have. To get the ram to run at it's 2666mhz speeds, you might have to set XMP/DOCP profile in your bios, so they run at full speed.
 

MKLninja

Commendable
Mar 17, 2019
218
6
1,595
2
Hey there,

So, 1066 actually = 2133mhz. The ram is DDR (Double data rate) so you multiply 1066 x 2 = 2133mhz effective speed.

Pleas list your PC specs. So we can tell what mobo you have. To get the ram to run at it's 2666mhz speeds, you might have to set XMP/DOCP profile in your bios, so they run at full speed.
(GPU) : NVIDIA GeForce RTX 2070 SUPER 8GB

(CPU) : AMD Ryzen 5 2600 Six-Core Processor

MOTHERBOARD : B450M BAZOOKA V2 (MS-7A38)

Power Supply Unit (PSU) : Corsair CX Series 550 Watt 80 Plus Bronze Certified Non-Modular

I wasn't sure if you needed everything so I just listed those, if you do let me know
 

keith12

Illustrious
Great, thanks.

So all you need to do is, go into your bios (Check your mobo manual for how to do that - Normally you press F10, ESC or sometimes F2 - your manual will tell you).

Go to the memory settings page and check the XMP box or choose the profile from a drop down menu, it should read the timings automatically. You then simply save and exit from the bios, and it should boot up with the right speeds.

Let us know how that goes.
 
Reactions: MKLninja

MKLninja

Commendable
Mar 17, 2019
218
6
1,595
2
Great, thanks.

So all you need to do is, go into your bios (Check your mobo manual for how to do that - Normally you press F10, ESC or sometimes F2 - your manual will tell you).

Go to the memory settings page and check the XMP box or choose the profile from a drop down menu, it should read the timings automatically. You then simply save and exit from the bios, and it should boot up with the right speeds.

Let us know how that goes.
I will test it and let you know, does that mean 1067Mz has been on instead of 2666Mz?
 

keith12

Illustrious
I went into the bios but I don't see what you are talking about
https://ibb.co/K5x1wcS This is what I see when I get on there, this isnt my picture just a example of what I see when I get on
Ok, so you're gonna have to look around in the bios. The settings a probably under the 'Overclocking settings'. Usually it's under 'memory' or XMP. Look around the menu's and different pages and you will find it. The bios looks scary, but it's not really.

Show us the options you get, and we can help you set the memory to run at the right speed (2666mhz)
 

ASK THE COMMUNITY