Question Ram is 3200mhz but running at 2933mhz

Jan 30, 2021
10
0
10
0
Bought a prebuilt pc called a orion predator 3000 has a custom motherboard from acer called PO3-620 it came with 2 8gb rams sticks with 3200mhz but only uses 2933mhz. Also having a freezing issue ever few hours when i use the app predator sense for my fans but when i uninstall im freeze free.
 

keith12

Illustrious
Hey there,

Well, the CPU max ram supported it 2933mhz, but it may work at higher speeds, but that could be limited by the mobo.

Go into your bios, and look for an XMP setting. Your mobo bios/uefi may not have it. If it does, then change it to the matched speed of your DIMMS, if the option is there. If it's not, there's not much you can do I'm afraid.

As for the app, causing issues, make sure your system drivers. gpu drivers are up to date and the app itself is the most recent version. If that doesn't help, look for older revisions of the app and check to see if it works as it should.
 
Jan 30, 2021
10
0
10
0
Hey there,

Well, the CPU max ram supported it 2933mhz, but it may work at higher speeds, but that could be limited by the mobo.

Go into your bios, and look for an XMP setting. Your mobo bios/uefi may not have it. If it does, then change it to the matched speed of your DIMMS, if the option is there. If it's not, there's not much you can do I'm afraid.

As for the app, causing issues, make sure your system drivers. gpu drivers are up to date and the app itself is the most recent version. If that doesn't help, look for older revisions of the app and check to see if it works as it should.
Thanks for the reply dont think there is an xmp in bios ill try finding a fix to the app.
 

ASK THE COMMUNITY