Question Ram isn’t being picked up

Sep 28, 2020
7
0
10
0
My BIOS picks up on 2 memory sticks. But the second is not being used or found even in Bios too. I can see both sticks of ram are installed, but the current DRawM size is : 8192, instead of arround 16k
Image: https://ibb.co/FmL7xBK
In windows, the ram usage says: 7.95/16gb (usable)
I am missing out on 8gb of ram but I cannnot seem to find where I am losing it. Any suggestions on how to to pick up on that second stick of ram?
 

PC Tailor

Judicious
Ambassador
  • Have you installed both modules as per the motherboard manual?
  • Are the modules from the same physical pack (not bought separately)?
  • Have you reset CMOS after installing the RAM?
  • Following those, have you tried each RAM module individually in the different slots?
 
Sep 28, 2020
7
0
10
0
  • Have you installed both modules as per the motherboard manual?
  • Are the modules from the same physical pack (not bought separately)?
  • Have you reset CMOS after installing the RAM?
  • Following those, have you tried each RAM module individually in the different slots?
1. Not sure per manual? I put them in A2 and B2
2.Yes same pack look exactly the same
3.Yes I did it and it didn’t make any difference
4.I tried A1 B2 and it didn’t make a difference.
 
Sep 28, 2020
7
0
10
0
  • Have you installed both modules as per the motherboard manual?
  • Are the modules from the same physical pack (not bought separately)?
  • Have you reset CMOS after installing the RAM?
  • Following those, have you tried each RAM module individually in the different slots?
I also tried to update Bios and now it looks like this: https://ibb.co/jk1Tqwp
I might have selected the wrong BIOS tho in the update
 
Sep 28, 2020
7
0
10
0
  • Have you installed both modules as per the motherboard manual?
  • Are the modules from the same physical pack (not bought separately)?
  • Have you reset CMOS after installing the RAM?
  • Following those, have you tried each RAM module individually in the different slots?
Update: My motherboard is the broken thing I’m pretty sure, tried to run just A2 and it would not work. So the A2 slot must be broken, not sure why it would pick up as 16gb ram total tho
 
Sep 28, 2020
7
0
10
0
So both RAM modules work EXCEPT when one of them is in slot A2?
A1 and A2 (by themselves) the computer won't connect (no signal on monitor screen) I have reset bios, I am looking into update it soon. However the bios shows there are 2 ram sticks, one in A2 and one in B2.
 

ASK THE COMMUNITY

TRENDING THREADS