Question RAM issues on Asus H97M-E board ?

Sep 9, 2022
2
0
10
0
Recently I bought a set of "unused" G skill ripjawZ f3-14900CL10Q 8gb x4 = 32gb
The Asus H97M-E QVL states the same ram can be used up to 64gb ( although impossible since it only has 4 slots with 8gb per slot total)

However when testing single sticks or multiples or moving them around from alot to slot. PC will not post. Only way I can get it to post is by running my old mismatched 1333/1866 Corsair and hyper x ram

Would I consider these DOA and fight to return and get money back or did I miss something , or I made a mistake and got the wrong RAM ?

This mobo does downclock anything above 1600 back down to 1600 as I am currently doing this now.
 
Last edited:
Recently I bought a set of "unused" G skill ripjawZ f3-14900CL10Q 8gb x4 = 32gb
The h97m-e QVL states the same ram can be used up to 64gb ( although impossible since it only holds 4 slots with 8gb per slot total)

However when testing single sticks or multiples or moving them around from alot to slot. PC will not post. Only way I can get it to post is by running my old mismatched 1333/1866 Corsair and hyper x ram

Would I consider these DOA and fight to return and get money back or did I miss something , or make a mistake and got the wrong ram...

This mobo does downclock anything above 1600 back down to 1600 as I am currently doing this now.
Did you reset CMOS/BIOS between changes ?
 
Sep 9, 2022
2
0
10
0
Did you reset CMOS/BIOS between changes ?

Yes. Since posting this I then had an idea to start with 2 of my old sticks in a2 b2 and fill a1 b1 with 2 of the new sticks for some reason this allowed me to read all 4 . I then started with another new stick in a2 and removed the old stick from b2. IT WORKED. Lastly I added in the 4th and final stick and wouldn't post. Then I was getting constant restarts. I removed every stick except the last and tried it in every slot alone with no post. I then tried pairing it with different combos and still no post. Rather than using only 3 of the 4 new ones I opted to use 2 of the new ones in parallel with my old HyperX fury and I get slightly higher speeds and lower latency running it that way than with just the 3 new ones
 

ASK THE COMMUNITY

TRENDING THREADS