Question RAM not running at 3200 mhz, I could use some help.

CakeBadger

Reputable
Jul 2, 2014
54
0
4,630
0
Hello. I'll try to be as concise and brief as possible. I recently built a new computer. When I was loading up windows, I realized my ram wasn't running at 3200mhz as the speed I bought for it. I took a screenshot of the bios and the task manager to show that it wasn't running at the correct speed. Keep in mind that I flashed my bios to the most recent update. Downloaded all my chipset, and lan drivers for the motherboard. Can anyone tell me what the problem is?

Here are my computer specs.

CPU: AMD Ryzen 7 2700x
GPU: RTX 2060 6GB
MOBO: MSI B450 Tomahawk.
SSD: WD Blue SSD
RAM: Corsair Vengeance LPX 16GB DDR4 3200 MHZ
PSU: Corsair RM650X
CASE: NZXT h500i

 

Crosslhs82x2

Notable
Aug 12, 2017
462
34
890
27
From the task manager shot it would be it's showing 1600.
Ran 3dmark firestrike when finished click compare online the results at the bottom of the page will tell you you speed.
 

Kvlt Doom

Distinguished
Feb 8, 2011
18
2
18,525
1
I took a look at the manual for your motherboard & on page 54 it instructs the user to do those steps I mentioned, Enable A-XMP (AMD eXtreme Memory Profile) & choose a profile, if available.
I see that Profile 2 has the speed set at 3200MHz, so select that.

Alternatively, if you are in Easy Mode, you can hit that circle in the A-XMP box in between the Game Boost button & where it shows the CPU Speed & DRAM Speed. This one is on Page 42.

Good luck.
 

CakeBadger

Reputable
Jul 2, 2014
54
0
4,630
0
I probably should have mentioned that I already tried that option and my memory still stays clocked at 1500mhz instead of the target 3200mhz. Is there a solution to this? I've taken a screen cap of my CPU-Z to show you that the memory is still a problem.

Sure. Look under DRAM Setting, where it says A-XMP is Disabled?

Enable that & select Profile 2. Save config & exit.
Enjoy speedier RAM!
I took a look at the manual for your motherboard & on page 54 it instructs the user to do those steps I mentioned, Enable A-XMP (AMD eXtreme Memory Profile) & choose a profile, if available.
I see that Profile 2 has the speed set at 3200MHz, so select that.

Alternatively, if you are in Easy Mode, you can hit that circle in the A-XMP box in between the Game Boost button & where it shows the CPU Speed & DRAM Speed. This one is on Page 42.

Good luck.
 

Satan-IR

Honorable
Apr 18, 2014
1,396
162
11,890
163
I probably should have mentioned that I already tried that option and my memory still stays clocked at 1500mhz instead of the target 3200mhz. Is there a solution to this? I've taken a screen cap of my CPU-Z to show you that the memory is still a problem.





That's OK. What you see is the RAM frequency, 1599.1 Mhz.

You have DDR RAM (Double Data Rate).

So you have to multiply that number by 2. 1599.1 x 2 = 3198.2 Mhz.
 
Reactions: Kvlt Doom and boju

ASK THE COMMUNITY

TRENDING THREADS