Question RAM not running at correct speed?

Jun 29, 2019
35
1
45
2
Well, title is self explanatory. Just learned through self study that RAM doesn't really run at correct speed when you put it on your motherboard as advertised even in modern builds like someone says, many don't know this that people are not aware their system is setting them by default where it is safe.

So my question is, is this speed correct? I'm doubtful about it.
CPU: Intel PENTIUM DUAL CORE E5700 3.00ghz
RAM: Kingston 2GB DDR3 1333mhz PC3-10700, Nanya Technology 2GB DDR3 1333mhz PC3-10700 (4GB all in all)
Board: Asrock G41M-VS3

CPU-Z says:
SPD: 667 (supposed to be)
DRAM Frequency: 398.8mhz
FSB-DRAM: 1:2
CL: 6
TRCD: 6
TRP: 6
TRAS: 15
TRFC: 64
CR: 2T

Can't find the XMP profile to enable it automatically as I'm too noob at overclocking alike though this is not literally overclocking. How and where should I enable them on BIOS exactly? Afraid to damage my computer as I'm using it for work everyday, whole day.

Thanks in advance.

NOTE: 1 month ago, I moved my parts to a new board from AM3 to LGA 775 so i'm a little bit surprised 1333 is already an OC for this board which is not for AM3's case. Noticed that I was lagging more on a certain game so it happened that I checked it through CPU-z. Don't ask why I moved to a new board, the former has a lot of problems already.
 

QwerkyPengwen

Dignified
Herald
if there is no XMP profile in BIOS to set, then set it manually to the speed and timings printed on the stickers on the RAM.

I am assuming though that all four sticks were purchased as part of a 4 stick kit correct?

Because otherwise running different brand/model ram at OC speeds (which for DDR3 is anything more than 800MHz I believe) can result in not being able to run them at the higher clocks due to memory compatibility issues and the fact they most likely will require different timings from each other which can make it very difficult to get them all working in sync with each other.
 
Jun 29, 2019
35
1
45
2
if there is no XMP profile in BIOS to set, then set it manually to the speed and timings printed on the stickers on the RAM.

I am assuming though that all four sticks were purchased as part of a 4 stick kit correct?

Because otherwise running different brand/model ram at OC speeds (which for DDR3 is anything more than 800MHz I believe) can result in not being able to run them at the higher clocks due to memory compatibility issues and the fact they most likely will require different timings from each other which can make it very difficult to get them all working in sync with each other.
Hmmm ok. Yea I have 2x2GB RAMs as mentioned. Different brand but same exact specs.. I don't have problem with that as I can just replace it with a single stick 4GB with the same exact spec also.

Too bad if that's the case I guess I really need to set it manually.. But how? I'm too confused right now as my bios seems to be not user friendly like the new ones. I know where on bios tho. Just the terms and everything. Also, how would I know the exact voltage, etc. to be inputted?

I have 1x4gb Kingston DDR3 1333mhz
 

QwerkyPengwen

Dignified
Herald
Sorry about that, I saw the 4GB total and for some reason though it was 4 x 1GB sticks LOL.

Don't go single stick as that will make things slower due to the lack of dual channel.

Just make sure that the two sticks are in proper slots for dual channel.

Channels are known by letters and slots per channel are numbered.

So for example, if you put both sticks into A1 and A2, that would be single channel and not efficient use of two sticks.

You would need to make sure they are in slots A1 and B1, or A2 and B2.

A2 and B2 are the typical slots for dual channel with just two sticks so use those slots.
Slots should be labeled on the motherboard right next to them.

Now, in the BIOS, you should head over to wherever you see settings for DRAM.
From there you set the speed and timings as printed on the labels.

Just like you saw in order from top to bottom in CPU-Z that you posted yourself, that is the order in which you apply each timing.

CL
TRCD
TRP
TRAS

Leaving everything else on auto.

The voltage should also be printed on the labels as well.

Stock voltages for DDR3 is 1.5v, but it may be tuned differently depending on the stick, so look for it.

If you can see it and/or there is not good information such as model number on the sticks, then use either Device Manager, or use CPU-Z to get the model number for the RAM and then just look the info up.

Once you've manually changed the settings for the RAM in BIOS, just exit saving changes and reboot into Windows.

Run CPU-Z and check the speed.
The speed of the RAM should be displayed as MHz and the number should be just about half of 1333 since DDR stands for Double Data Rate
 
Jun 29, 2019
35
1
45
2
Sorry about that, I saw the 4GB total and for some reason though it was 4 x 1GB sticks LOL.

Don't go single stick as that will make things slower due to the lack of dual channel.

Just make sure that the two sticks are in proper slots for dual channel.

Channels are known by letters and slots per channel are numbered.

So for example, if you put both sticks into A1 and A2, that would be single channel and not efficient use of two sticks.

You would need to make sure they are in slots A1 and B1, or A2 and B2.

A2 and B2 are the typical slots for dual channel with just two sticks so use those slots.
Slots should be labeled on the motherboard right next to them.

Now, in the BIOS, you should head over to wherever you see settings for DRAM.
From there you set the speed and timings as printed on the labels.

Just like you saw in order from top to bottom in CPU-Z that you posted yourself, that is the order in which you apply each timing.

CL
TRCD
TRP
TRAS

Leaving everything else on auto.

The voltage should also be printed on the labels as well.

Stock voltages for DDR3 is 1.5v, but it may be tuned differently depending on the stick, so look for it.

If you can see it and/or there is not good information such as model number on the sticks, then use either Device Manager, or use CPU-Z to get the model number for the RAM and then just look the info up.

Once you've manually changed the settings for the RAM in BIOS, just exit saving changes and reboot into Windows.

Run CPU-Z and check the speed.
The speed of the RAM should be displayed as MHz and the number should be just about half of 1333 since DDR stands for Double Data Rate
Just for clarification.. I have only 2 slots.. with 2 pcs of 2gb RAM 1333mhz (Kingston and Nanya Technology) seated in.

But if you won't recommend 2 different brands even if it's the same exact spec for the purpose of OC-ing, I can just put in 1 4GB RAM with also same exact spec as I have spare parts lying around.

But oufcouse, thanks by the way for the fast response. I really appreciate it. I'll try that and will update you about the result.

By the way, can this cause BSoD or something? I really don't want to format my computer if that happens (business purpose) or I can just reset my CMOS battery if something bad happened?
 

QwerkyPengwen

Dignified
Herald
if you run into any errors that result in crashing, locking up or anything after setting the RAM speed and timings, then all you need to do is revert the settings back to default and at that point you'll know they aren't compatible and if you want the higher speeds but not nearly as fast and efficient as dual channel, you can simply just slot in the single 4GB stick.

be sure that when you go to remove the sticks that you do the following:

Shut down computer.
Turn it back on and go into BIOS and revert to defaults.

Save and exit, then during BIOS post screen press and hold power button to just turn it off.

Flip switch on back of power supply if you have one, otherwise completely unplug the cable from it.
Press and hold the power button on PC for 10 seconds to drain any residual energy.

Then go ahead and remove sticks and plug in new stick.
Flip switch back (or plug back in if having removed cable) then power on system and go into BIOS and set the speed and timings of the new single stick then save and exit and let it boot to Windows like normal.
 
Jun 29, 2019
35
1
45
2
if you run into any errors that result in crashing, locking up or anything after setting the RAM speed and timings, then all you need to do is revert the settings back to default and at that point you'll know they aren't compatible and if you want the higher speeds but not nearly as fast and efficient as dual channel, you can simply just slot in the single 4GB stick.

be sure that when you go to remove the sticks that you do the following:

Shut down computer.
Turn it back on and go into BIOS and revert to defaults.

Save and exit, then during BIOS post screen press and hold power button to just turn it off.

Flip switch on back of power supply if you have one, otherwise completely unplug the cable from it.
Press and hold the power button on PC for 10 seconds to drain any residual energy.

Then go ahead and remove sticks and plug in new stick.
Flip switch back (or plug back in if having removed cable) then power on system and go into BIOS and set the speed and timings of the new single stick then save and exit and let it boot to Windows like normal.
I see, thanks :) Will give an update.
 
Jun 29, 2019
35
1
45
2
if you run into any errors that result in crashing, locking up or anything after setting the RAM speed and timings, then all you need to do is revert the settings back to default and at that point you'll know they aren't compatible and if you want the higher speeds but not nearly as fast and efficient as dual channel, you can simply just slot in the single 4GB stick.

be sure that when you go to remove the sticks that you do the following:

Shut down computer.
Turn it back on and go into BIOS and revert to defaults.

Save and exit, then during BIOS post screen press and hold power button to just turn it off.

Flip switch on back of power supply if you have one, otherwise completely unplug the cable from it.
Press and hold the power button on PC for 10 seconds to drain any residual energy.

Then go ahead and remove sticks and plug in new stick.
Flip switch back (or plug back in if having removed cable) then power on system and go into BIOS and set the speed and timings of the new single stick then save and exit and let it boot to Windows like normal.
Now this one bugs me out and seems to be not working. I replaced the 2 2GB ram with 1 4GB ram just to make sure and eradicate compatibility problem. Still, it runs on the same frequency as show on the image below:
View: https://imgur.com/jwNXKyi


I OC'ed it already at:
9-9-9-24 @1.50v
The frequency also bugs me out as it only shows DDR3 400mhz and has a notice showing if I adopt 1333mhz ddr3, I need to short the FSB1 pin (2-3). Did it already but still no luck. Can't see any sign of 1333mhz speed on my bios so I set it to "auto".

THE MAIN PROBLEM:
CPU-Z clearly shows my ram is running at:
400mhz (800mhz) instead of 666mhz (1333mhz)(OC)


That fsb1 is bugging me out big time. BIOS keeps rolling back to default. can't also see any sign of 666mhz frequency choice.. only 400mhz.
 
Last edited:
Jun 29, 2019
35
1
45
2
if you run into any errors that result in crashing, locking up or anything after setting the RAM speed and timings, then all you need to do is revert the settings back to default and at that point you'll know they aren't compatible and if you want the higher speeds but not nearly as fast and efficient as dual channel, you can simply just slot in the single 4GB stick.

be sure that when you go to remove the sticks that you do the following:

Shut down computer.
Turn it back on and go into BIOS and revert to defaults.

Save and exit, then during BIOS post screen press and hold power button to just turn it off.

Flip switch on back of power supply if you have one, otherwise completely unplug the cable from it.
Press and hold the power button on PC for 10 seconds to drain any residual energy.

Then go ahead and remove sticks and plug in new stick.
Flip switch back (or plug back in if having removed cable) then power on system and go into BIOS and set the speed and timings of the new single stick then save and exit and let it boot to Windows like normal.
I'm really sorry for wasting your time. Problem solved and another lesson for me :) Thanks for helping.

It seems like the max FSB my CPU can handle is 800mhz (that's why it's stucked at 400mhz frequency and nothing else I can do. Looks like I need to buy another CPU probably intel core quad or xeon to make this 1333mhz work out. I guess shorting the 2-3 fsb pin is useless for this CPU.

Thanks. I really appreciate your time and effort.

View: https://imgur.com/bl0Hm7F
 

ASK THE COMMUNITY

TRENDING THREADS