[SOLVED] RAM not running at intended freq


Nov 16, 2016
I am having an issue with my ram. As you see my viper patriot rgb 16 gb (8*2) is running on 2132. If I change this to anything above 2132, my system will turn off after saving, turn on for a second and then turn off, repeat and then turn on with ram running at 2132 again.

I have an asrock x470 fatal1ty with the latest bios, the ram stick I just reffered that actually should run at 3000 and ryzen 5 2600.

I have not overclocked anything. I read somewhere about placing ram stick on a1 and a2 solved the issue for a guy. I also read about overclocking CPU and about giving more voltage to CPU or RAM or both together. What do you think?
For RAM placement look up in the manual, most Ryzen platform states A2 and B2 slots.
Some MBs XMP call AXMP or DOCP, that has to be set first.
Overclocking CPU is not necessary for RAM to run at set speed and vice versa, each one can be overclocked independently.
XMP is actually a set of instructions for BIOS to set it to proper frequencies, latency and voltage. Except for setting XMP/AXMP or DOCP, you shouldn't have to change anything.