[SOLVED] Ram not Working - ASUS ROG Z370 ATX gaming motherboard

Apr 16, 2020
3
0
10
0
Hello! First-time post here!

So I recently got two new sticks of 8GB Ram team t force DDR4 3200 in addition to my two sticks of 8GB Ram T-FORCE DDR4 3000.

I have the ASUS ROG Z370 ATX gaming motherboard and am having trouble figuring out why the new ram won't work. I can only boot the system with ram in slots 1 & 2 (either stick or mix of speed works and boots) but if I put any stick in slots 3 or 4 it beeps but doesn't post.

I have done:

  • Reseating the GPU
  • Reseating RAM
  • BIOS Update
  • Tested all ram in my girlfriends PC, boots like a charm.
The RGB lights on the RAM come on when they are plugged into slots 3 and 4, so they definitely get power.

Any insights or tips that could help - just hoping it's not dead RAM slots. I see no physical damage on the board at all.

Thanks in advance!
 
Apr 16, 2020
3
0
10
0
If you got it through amazon, try to return it. The ram has gotta be the same brand AND speed. I'm curious, what do you need 32GB for?
Thanks for the reply! I got the RAM through newegg.ca and the motherboard from a friend who was upgrading his board. I was looking to upgrade to 32GB for better performance in Adobe programs - photoshop and premiere pro mainly.
 
Apr 16, 2020
3
0
10
0
If you got it through amazon, try to return it. The ram has gotta be the same brand AND speed. I'm curious, what do you need 32GB for?
Update: I have gotten the board to boot to windows and recognize all 4 sticks in BIOS, but windows still only recognizes two sticks and 16GB
 

jwcrellin

Reputable
Dec 3, 2016
1,410
37
5,690
162
Examine the cpu socket for bent pins. Also, sometimes incorrect mounting pressure from the bracket metal arm or the cpu cooler can cause memory issues. I remember linus couldn't boot a Xeon processor because he didn't have sufficient mounting pressure, he ended up stacking books and stuff on top of the heatsink.
 

ASK THE COMMUNITY