Question RAM not working in Dual Channel mode ?

Nov 16, 2021
5
0
10
0
Hey pros,
I will keep it short, I tried to find a solution to an issue i am having but couldnt, so you guys are my last resort.
I have an MSI z270 pro, on which i was using 4 rams - (8gb Corsair DDR4 ,3000 mhz) without any problems in the past, but i had to move and changed my cabinet and since then my mobo isnt recognizing more than 2 rams,
The Ram slots are DIMMA1 DIMMA2 DIMMB1 DIMMB2
i tried 1-3 2-4 slots, All 4 slots, switching all possible combinations, but it wont recognize,

currently i am stuck with using DIMMA1 and DIMMA2 and DIMMB1 DIMMB2 dont work if i use any rams in DIMMA1.

All 4 rams are working fine ,
Did my mobo switch to single channel ? is there a way to make it use dual channel?
anything i need to do in bios?
what do i do to use all 4 slots ? HELP!!!
 
Nov 16, 2021
5
0
10
0
Yes, thanks for the suggestion mike, i will check that.
I was thinking that maybe there is a bent socket pin issue, I have never messed around with those, how sensitive are those incase i need to adjust it? :unsure:
 
Yes, thanks for the suggestion mike, i will check that.
I was thinking that maybe there is a bent socket pin issue, I have never messed around with those, how sensitive are those incase i need to adjust it? :unsure:
That's one problem with that kind of socket, pins are very thin and fragile. There are multiple Youtube and other instructions how to deal with it.
 
Nov 16, 2021
5
0
10
0
For anyone who had a similar issue - There was a problem with one of my pins on the cpu, it was bent, everything working fine since i fixed it.
 

ASK THE COMMUNITY

TRENDING THREADS