Question RAM Related Issue With GA-A320M-S2H Motherboard

Feb 20, 2021
11
0
10
0
Hello,

I am currently undergoing a struggle with my 2 DDR4 RAM sticks as I am trying to seek a solution towards getting a fix for my computer issue.

To begin with, I have listed my overall specs below;

Graphics Card: Nvidia GTX 1050TI
RAM: 8GB 1R*8 PC4 3000 16-18-18-36 HP V6 DDR4 (x2)
Processor: Ryzen 7 2700x
Drives: 500GB SSD & 1TB HDD
PSU: 500 Watt Power Supply
Motherboard: GA-A320M-S2H
To start off, I got my computer prebuilt from Skytech. here's there website: https://skytechgaming.com/
After a while of owning my computer, Skytech offered to send me an extra 8GB of RAM so that in total I can have 16 GB of RAM. The reason for this offer is because the components that my computer came with, minus the SSD and Ryzen 7 processor, it was all outdated components, thus they offered me an extra RAM stick. I originally had a Ryzen 3 1200 CPU. When I inserted the RAM stick into a free RAM slot in my computer and turned the system on, my computer would then turn off and on twice and when it actually turned on, it would display no picture on my monitor. I thought this was kind of strange so what I did was physically shut down my computer and power it back on again and when I turned it back on, my computer would then successfully go by POST and properly go into my operating system. I then went onto task manager to see if my 2 RAM sticks are displayed and it turns out that they are displayed, however, in task manager it states that I have 8GB of RAM in Hardware Reserved, thus my computer is only using 8GB and not 16GB of RAM.
I went into BIOS and clearly BIOS does recognize that I have two RAM sticks installed, it's only my computer that is struggling. I tried turning Extreme Memory Profile on and off multiple times and there would be no result. I also noticed that when I inserted my other RAM stick, the RAM speed would go down to 2666MHz from it's original speed, 3000MHz. I also tried switching the RAM sticks around and trying one RAM stick at a time and they both work really well individually.

By any means, does anyone know a solution for my computer issue?

And also, followed by this website it states that with my Ryzen 7 2700x processor, I am able to go up to 32 GB of RAM with my current owned motherboard: https://pcpartpicker.com/products/motherboard/?compatible_with=bddxFT
 
Last edited:

Lutfij

Titan
Moderator
500W is the wattage of the unit. What is the make and model of the PSU? You're advised to make sure you're on the latest BIOS version for your motherboard prior to dropping in any hardware on the motherboard, be it a new(or old) processor, a new kit of ram, SSD's or GPU's.

Can you check and see which BIOS version you're currently on, while using the original stick of ram that the system came with?
 

ASK THE COMMUNITY

TRENDING THREADS