Question RAM running slower than stated

Dani R

Honorable
Sep 29, 2014
5
0
10,510
0
Hi,
I just bought and installed some new RAM in my system. 16gb (2 x 8) corsair vengeance rgb pro 3200mhz. However, cpu z and task manager both say it's running at 2133 mhz. I've tried changing a-xmp profiles and tried disabling and running at 3200 mhz. Upon reboot, system crashes before post and then reboots again running at 2133. I have tried updating the bios but the problem still occurs. Help please?
Cpu: ryzen 7 2700x
Mobo: b450 gaming plus max
 
Mar 1, 2020
12
2
15
0
I had a similar problem with my tridentz neo 3600mhz kit. It would just run at 2133. Sometimes you gotta manually put in the ram speed and timing configuration. Also the soc voltage and memory voltage
 
Mar 1, 2020
12
2
15
0
Try this it worked for me.
Go to your oc tab in bios
Go to your dram frequency select the next MHz higher then 2133 on the drop down menu
I didn’t load xmb profile
Set manually the memory voltage to 1.350v (You can try higher like 1.400v too)
Set the SOC voltage to 1.1250v
Then go to dram timing configuration
Enter the configuration your ram kit recommends ( mine was 16-19-19-19-39)
Disable Gear Down and Power Down mode
Save and exit
If windows accept the frequency and starts up, restart, go to bios and increase the memory speed again. Each time u go into bios up the ram speeds mhz. You can load windows at each interval to test the stability. Wash rinse repeat until you've reached the 3200mhz.
 
Reactions: Nemesia

Dani R

Honorable
Sep 29, 2014
5
0
10,510
0
Try this it worked for me.
Go to your oc tab in bios
Go to your dram frequency select the next MHz higher then 2133 on the drop down menu
I didn’t load xmb profile
Set manually the memory voltage to 1.350v (You can try higher like 1.400v too)
Set the SOC voltage to 1.1250v
Then go to dram timing configuration
Enter the configuration your ram kit recommends ( mine was 16-19-19-19-39)
Disable Gear Down and Power Down mode
Save and exit
If windows accept the frequency and starts up, restart, go to bios and increase the memory speed again. Each time u go into bios up the ram speeds mhz. You can load windows at each interval to test the stability. Wash rinse repeat until you've reached the 3200mhz.
I tried that and it still didnt work. What I did find was that in MEMORY-Z for both DIMMA2 and DIMMB2 the max bandwidth says 2133(1066MHz) despite them supposedly being 3200MHz.
 
Mar 1, 2020
12
2
15
0
Oh damn. On my set at first my motherboard couldn’t accept the 3600mhz so I had to settle for 3334mhz. But the I upgraded to a gigabyte X570 Aorus elite motherboard and has able to get my 3600mhz
 

ASK THE COMMUNITY

TRENDING THREADS