Question RAM Slots not working anymore

Feb 19, 2019
3
0
10
First of all I'd like to excuse my english, hope you will understand everything, if not please ask for clarification!

I've had a problem for a long time and now I'm finally trying to solve it.
My PC always ran with my 2x 4GB of RAM in the dual channel (A1 & B1) and everything is compatible, was set up in the right slots and worked like it should and at some point I suddenly got bluescreens and the PC was simply no longer usable.
No idea why it all came up, but since then I've just stuck one RAM bar in the first slot A1, everything is working now and that's been going on for over a year now.
But as soon as I try to use both bars it doesn't work.

For A1 & B1, as well as for the combination A2 & B2 the following message comes up when booting the PC:

"The following Channel Memory did not pass CPU memory test. Please remove the memory then plug again. Channel B"

I have also tested both RAM bars individually in A1 & A2 and both times the PC recognizes 4GB RAM.
Due to the message, I assumed that the two slots B1 & B2 are defect from my mainboard, then I have, although it is not recommended, put both bars in A1 & A2.
The PC started and recognized 8GB of RAM, I was happy at first. A short time after using the computer for an hour or so, however, the old problem again, blue screen.
After that I removed the second RAM bar and just put one in the first slot like usual.

I've also looked closer at the CPU if there were any bent pins, but everything was fine.
Then someone told me to update my UEFI/BIOS and I did, I had 1.60 and the most recent one for my mainboard was 2.50, I updated it and the problem is still there.
After that I was told that it could also be a problem of the CPU and I should test my system with a different compatible CPU and see if that solved my problem, which I haven't done yet.

So the problem is probably my CPU or my Mainboard and I really want to solve this problem after more than a year now.

My budget unfortunately does not allow me to put together a completely new PC, so I just want to replace the probably broken mainboard (or CPU) and I would be happy to get some cheap recommendations from you, but of course it must be compatible with my current system. I'm having a hard time with only 4GB of RAM and I want to finally be able to use my full 8GB again.

Before I buy anything though, I'd really want to be sure that it solves my problem, that's why I haven't bought a cheap compatible CPU yet because it could be the mainboard that causes my issues and that's why I'm asking for help here, to hopefully find out what causes my problem.

My system is more than 5 years old, and I know that it would be better to just wait to buy a whole new system, but if I have my 8GB of memory again, I will definitely still use this computer for 2 more years.

Thanks in advance for anyone who's trying to help!

Here is my complete system:

Mainboard: ASRock B85M Pro4 Intel B85 So.1150 Dual Channel DDR3 mATX
Case: BitFenix Shinobi USB 3.0 Midi Tower without power supply
CPU: Intel Core i5 4570 4x 3.20GHz So.1150 BOX
CPU Cooler: EKL Alpenföhn Brocken Tower Cool
Case Fan: Enermax TBSilence 120x120x25mm 900 rpm 11 dB (A)
Main memory: 8GB Crucial Ballistix Sport DDR3-1600 DIMM CL9 Dual Kit
Hard Drive: 1000GB Seagate Desktop SSHD ST1000DX001 64MB 3.5 "(8.9cm) SATA 6Gb / s
Power Supply: 500 Watt be quiet! System Power 7 Bulk Non-Modular 80+ Silver
Graphics Card: 2GB Gigabyte GeForce GTX 770 Windforce 3X Active PCIe 3.0 x16
Drive : Samsung SH-224DB / BEBE DVD-RW SATA 1.5Gb / s
 
It could be the motherboard or the RAM.
I do not think is the CPU.
Did you ever tested the RAM kit with Memtest86+?

I would try resetting the motherboard to factory default, in case there is a RAM setting preventing the RAM from working properly.
Then insert the RAM kit in slots A2-B2 or A1-B1 for dual channel.
If you place the RAM kit in any other configuration might work (A1-A2, B1-B2, A2-B1 or A1-B2 ) but it will work as single channel.

You could get a similar motherboard used from eBay or Amazon.
 
Feb 19, 2019
3
0
10
Thanks for your answer!

No I haven't tested my RAM with Memtest86 but when this problem originally occured, I thought my second RAM Bar was defect so under guarantee I got a new one but the same problem. I'm pretty sure it's not the RAM but maybe I try something like this Memtest.

With Resetting the motherboard to factory default, do you mean a CMOS reset?
Some people told me to do that as well, but I wanted to know if I need to do it with the jumper or does it work also if I do it from the BIOS Menu iteself by loading default settings, then save & exit? Because that sounds a lot easier to do than the jumper method
 

ASK THE COMMUNITY

TRENDING THREADS