[SOLVED] Ram stability ryzen feedback

Aug 1, 2020
6
0
20
1
So yeah, i have tried 3 different motherboards 3 sets of ram.

In the end i'm with a ryzen 5 3600, b550 pro, and Patriot PVR416G320C6K Viper RGB Series DDR4 16GB (2 x 8GB)

https://assets.website-files.com/5cdb2ee0b102f96c3906500f/5dd5c1f3bfa2907363c3d081_PVR416G320C6K_16GB_3200_Kit.pdf

None of the timings recommended by the manufacturer where even posting.

I've tried using the safe timings from Dram ryzen calculator: 14-14-14-28 - won't even post.

My best stable timings are 16-16-16-32. I managed to have up to 2 days without a crash.

Why is this so annoying to get it right? Any feedback is appreciated, thank you all!

Update:

Ok, so only when i manually put in bios the frequency multiplier to 16 (1600mhz) i get in cpu-z Command Rate(CR) 2T, on any other frequency that is above that i get 1T in cpu-z basically lowering my ram stability....
https://ibb.co/vVNZBnN

Update2:


So yeah, i've tried to do auto subtimings and they went to 16-18-18-38, seemed more stable but after 5 min i got blue screen, trying now 14-16-16-32.....
 
Last edited:
Aug 1, 2020
6
0
20
1
FIXED: Remove Cpu-Z from pc ... no more crashes!

The reason it didn't crash that time for 2 days was cause i didn't check cpu-z for timings. Every time i was changing timings i was using that program to check and 2 minutes into games i got crashes.

I have uninstalled cpu-z and everything working fine, on optimized defaults or xmp profile 1, no issues :)
 
Last edited:
Aug 1, 2020
6
0
20
1
Yes, there was nothing changed stability in the new f2 bios. Except that now my rams names went from 'unknown' to blank :)

Funny story, i've checked the motherboard manufacturer QVL list and bought those rams using this information. They booted and worked for 2 hrs, after a pc restart it will not even boot :) now i have to pair it with another pair of rams that are not in the qvl but it's the only way that it boots.

I have attached my cpu-z details: https://valid.x86.fr/33sc48

I have also tried to disable/enable both C6 in bios, so that the voltage would not fluctuate, still didn't improve my stability.
 
Last edited:
Aug 1, 2020
6
0
20
1
After 20 or so tests with all the JEDEC recommended settings all crashed after 2 min.

For now 1600MHZ - 16-16-16-32 and also manually setting TRC to 48 after the formula i found on wikipedia still seems to be the most stable. Normally my bios sets the TRC to 60 and it seems to be too high in my opinion. it's also the only way for me to see 2T in the cpu-z.

But i still get the occasional crashes after 1-2 days, usually i get them in the morning when i boot my pc, after it's gotten warm he seems to stabilize even more, might that have anything to do?
 
Yes, there was nothing changed stability in the new f2 bios. Except that now my rams names went from 'unknown' to blank :)

Funny story, i've checked the motherboard manufacturer QVL list and bought those rams using this information. They booted and worked for 2 hrs, after a pc restart it will not even boot :) now i have to pair it with another pair of rams that are not in the qvl but it's the only way that it boots.

I have attached my cpu-z details: https://valid.x86.fr/33sc48

I have also tried to disable/enable both C6 in bios, so that the voltage would not fluctuate, still didn't improve my stability.
Mixing RAM like that maybe your problem. That's why it's not recommended, not only are they different manufacturer but also of different speeds and latency as well as architecture.
 
Aug 1, 2020
6
0
20
1
Mate, the qvl approved ram (2x8gb patriot) won't even boot. the old 8gb kit will boot on it's own but it crashes even like that.
Also i need at least 14 gb ram to run my applications, that's why i bought them.

I know it's a bad situation, but i'm tired of sending and receiving parts that don't work. 3 cpu's, 3 motherboards, 3 sets of ram, 2 video cards, another pc from a friend. they all sit here in my room, it looks like a pc part shop now.

Just want something to work and not crash...over a month of fiddling and getting 0 work done is annoying.
 
Aug 1, 2020
6
0
20
1
FIXED: Remove Cpu-Z from pc ... no more crashes!

The reason it didn't crash that time for 2 days was cause i didn't check cpu-z for timings. Every time i was changing timings i was using that program to check and 2 minutes into games i got crashes.

I have uninstalled cpu-z and everything working fine, on optimized defaults or xmp profile 1, no issues :)
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS