RAM Suddenly Stops Working on Current Computer But Works on Another

harry.huang08

Prominent
Aug 16, 2017
2
0
510
0
For the sake of simplicity, I will refer to the two computers in use as "New Computer" and "Old Computer." My new computer has 4 X 8 GB of G.Skill Trident Z RGB 3000 MHz memory and my old computer has 4 X 4 GB of Crucial Ballistix Sport LT 2400 MHz memory. My new computer's motherboard is the MSI - Z270 XPOWER GAMING TITANIUM ATX LGA1151 Motherboard, and my old computer's motherboard is the ASRock - B450M PRO4 Micro ATX AM4 Motherboard. Both are running Windows 10 Pro 64.

The problem all started on my new computer when I was watching Youtube and was shocked to see the video undergo a visual graphics malfunction that resembled that of a technical difficulties screen. I thought that this was simply an issue with the video so I scrubbed the video back a few seconds and found out that the visual malfunction occurred at the same time in the video. This continued to happen for a few days so I decided to see if there was something wrong with my graphics card. I opened deviced manager and updated my graphics card (Asus ROG Strix 1080 Ti) drivers. Then suddenly, I got a BSOD stating "memory_management." *Note* for the two days prior to this, I had received multiple BSODs related to kernel errors; these were fixed with updating Windows and running "sfc /scannow" in a cmd window ran as an admin.

After getting the BSOD, I rebooted and ran a Windows Memory Diagnostic, which told me that there were hardware issues and that I should contact my computer manufacturer. Afterwards, I turned off my computer, switched off the PSU, and took out all of the RAM sticks except for the one in slot A1, turning my computer back on and running another Windows Memory Diagnostic, whcih stated that there were no hardware issues. After completing the diagnostic on that one stick, I repeated the process two more times, each time using a different stick, each stating the same result. Coincidentally, the last stick that I tested, (I will refer to it as stick 22 as it ended with 22 in its serial number) was the one that had an issue, stating that there was hardware issue detected during the diagnostic, instructing me to contact my computer manufacturer. So, I did; I have my G.Skill RMA forms and I'm all ready to ship them out.

This occurred on a Friday night, so I tested this all throughout Saturday. I was also out of the home while the post office was open, so I was unable to ship it out. The next day was Sunday, so I was also not able to ship my RMA package. Being curious, I decided to see if my memory REALLY had an issue, because I was skeptical on whether or not the RAM, which had been in use for around 4 months, really would just stop working all of a sudden. So, I took my old computer, which I hadn't used in 2 months, updated everything. I updated Windows 10 as usual through the "check for updates" feature in the settings, but, this time I updated my graphics (EVGA Geforce GTX 1060 6GB) through GeForce experience, checking for updates with the driers. Then, I replaced the old computer's 4 sticks of Crucial Ballistix Sport LT 2400 MHz RAM with the G.Skill RAM, running a Windows Memory Diagnostics with the full 32 GB of RAM inside. I was shocked to find out that there was no message stating that there were hardware errors. So, I repeated the same exact process of testing each individual stick. I tested stick 22 last, which shockingly also stated that there were no hardware issues.

I took my new computer and put the old computer's 4 sticks of crucial ballistix sport lt ram into it, running the same tests, first with the group memory diagnostic and then with the indivual diagnostics, which all stated that there were no hardware issues. It was also at this point when my computer somehow got stuck in a automatic repair and disk repair loop that was only solved by pressing a key prior to the 8 second timer for disk repair. I skipped disk repair and reset my computer entirely, after backing up my data, of course. A fresh install of Windows 10, graphics driver update for my 1080ti, this time through GeForce experience, and a BIOS flash later, I was hopeful that my RAM problem would be solved. Nonetheless, stick 22 still has the same issues when running a Windos Memory Diagnostic.

I doublechecked everything between the two systems to find out the constants. Each system was running the same version of Windows 10 and had graphics cards that were updated through the same method (I first got the memory_management BSOD after a graphics card driver update so I thought that may be the issue). I'm truly stumped over this problem. Is there a problem with stick 22? Why does it show up as no hardware errors on my old computer, but is detected as having hardware errors on my new computer? Please help me solve this before I send the sticks out for RMA.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS