RAM throttling my machine?

iahwhite

Distinguished
Jul 29, 2009
73
0
18,630
Hey guys,

So I have been playing guild wars 2 and my fps dips to like 20 sometimes. I play bf3 and skyrim on max setting no problem but gw2 is killing me. I have been doing lots of research and I THINK it might be my ram. Here are my specs, please tell me if my RAM is messed up or something.

Motherboard: ASUSTEK M4A78T-E

CPU: AMD Phenom xii 945 3.0ghz

GPU: ATI Radeon HD 9670 2gb

RAM: 12gb of Corsair DDR3, dual channels, NB Frequency ~2100 MHz, DRAM Frequency 560 MHz, FSB:DRAM 3:8, (CL-tRCD-tRP-tRAS-tRC) 7-7-7-20-27

Sorry if this information is not enough I am a noob. Please let me know if you need more information and if you have any suggestions! Thanks!
 

sscultima

Honorable
Jun 5, 2012
460
1
10,810
are you using CPU-Z to bring up that information?

the memory based on the frequency would only come out to be 1120MHz, so i think something is not set properly, and what size are your memory modules? 2x4GB and 2x2GB? are they all the same brand and latency?
 

mikes1992

Honorable
Mar 27, 2012
292
0
10,810
you mean you're using a 6970 as opposed to a 9670... unless you're message is from the future and it which case your GPU is not supported.... hahaha JK

Anyway.

My guess is you're using 12GB of DDR3-1066. But your ram should be fine (especially since you have 2GB of GDDR5 video memory as well). I'd recommend upgrading your drivers... older drivers sometimes have problems with new games.

Also I've heard comments about bad performance dips in guild wars 2, I've not yet played it my self so I'm not too sure. but instability's are normally fixed by developers and distributed as updates (this stuff happens all the time with new releases).
 

blakwidowrsa

Honorable
Aug 10, 2012
277
0
10,810



I have a hunch your cpu cant keep up with tha card and your ram timings, GW2 uses Havok for physics, leaving the cpu to do physics calculations,adding extra overhead to the CPU, and causing the card to wait for the CPU/RAM due to wacky timings,I think 7-7-7-21 is standard for 1066 ddr3ram.

Reset your bios settings to default/optimized and reboot so motherboard can detect stable/'safe' timings.See if it makes a difference.and slowly increase/overclock your ram again...
Im guessing someone was trying to be too clever with latency timings....or as mikes1992 suggested wait for a patch...^^ :bounce: