Question Random black screen crash/reboots

Feb 9, 2021
3
0
10
0
Hi Guys,

wondering if anyone could help me with my PC's problem.

3 weeks ago i built the PC myself, I've had zero issues for the past 2 weeks but within the last week the PC will black screen and randomly reboot whilst playing games. i can sometimes play for About 10-20 minutes before experiencing the crash/reboot. Most reboots windup in the PC not showing anything on screen at all and me having to perform a second reboot at the tower to rectify this. I've upgraded my RAM today as i thought it might have been this that was causing me issues, but this hasn't fixed the problem. I'm stumped and really don't know what to do next.

my hardware is,
Sahara P75
AMD Ryzen 5 2600
MSI B450 Tomahawk MAX
Corsair RGB PRO 16gb
ASUS Radeon RX580
EVGA 500W PSU

Cheers,
Chris.
 
Hi Guys,

wondering if anyone could help me with my PC's problem.

3 weeks ago i built the PC myself, I've had zero issues for the past 2 weeks but within the last week the PC will black screen and randomly reboot whilst playing games. i can sometimes play for About 10-20 minutes before experiencing the crash/reboot. Most reboots windup in the PC not showing anything on screen at all and me having to perform a second reboot at the tower to rectify this. I've upgraded my RAM today as i thought it might have been this that was causing me issues, but this hasn't fixed the problem. I'm stumped and really don't know what to do next.

my hardware is,
Sahara P75
AMD Ryzen 5 2600
MSI B450 Tomahawk MAX
Corsair RGB PRO 16gb
ASUS Radeon RX580
EVGA 500W PSU

Cheers,
Chris.
  • What model is the EVGA power supply?
  • Is the power supply brand new? If not, how old?
  • What is the model of the new memory kit?
  • What storage drive(s) are you using?
  • Is your drive with windows OS used or new?
  • If it's a used drive, did you do a complete wipe and fresh windows install?
 
Feb 9, 2021
3
0
10
0
Archaic, sorry i should have mentioned those points.

the EVGA PSU is a 500W, Fully Wired 80PLUS, SLI/CrossFire, Single Rail, 40A +12V, 120mm Fan, ATX and its brand new.
new memory kit is Corsair Vengeance RGB pro 16GB @ 2666MHZ

My storage drives are both brand new, 500gb SSD and a 1Tb HDD

hope this helps.

Chris
 

ASK THE COMMUNITY

TRENDING THREADS