Question Random Black Screen w/ pc still running

Jun 9, 2021
3
0
10
0
Hi there,

I’ve encountered what so far has been an inexplainable issue with my PC. The monitor randomly goes black while the pc is still running. My monitor then gives the message that there is nothing connected, as is the case when it’s powered on before I boot up my pc. Also nothing can bring my monitor back besides forcing a shutdown of my pc (holding the power button) and rebooting. I’ve spent days googling this issue with no luck.

My Pc is the “PCCG Eclipse 2070 Gaming System” purchased in May last year.
Build: https://www.userbenchmark.com/UserRun/43732009#GRAPHICS_CARD

Initially I thought COD Warzone was the issue as most times it blacked out was while I was playing this game, which hints to my pc failing under load. However, this issue has occurred whilst simply web browsing or while in a zoom call with no other major background apps running. I have been monitoring temperature and cpu/gpu percentages and it’s nothing out of the ordinary when the issue happens. Event Logs also don’t report anything worth mentioning besides the forced shutdown I inevitably do.

For clarity, the system doesn’t reboot as I have been on discord with friends when it has happened multiple times and still been able to talk to them after the fact, as well as hear media sounds if they were playing at the time. The timing of it seems random as well because I could play Warzone for 4 hours straight and have no issue or play for 15 minutes and have it happen. My pc is a pre build from pccasegear which I received around May last year and has worked flawlessly until now. When the issue first arose, there were no new/recent programs installed on my pc which could have triggered some sort of change as I have always just used Games/Discord/Chrome.

From the research I have done, I have tried these solutions:
Updating graphics card drivers
Switching from dvi to hdmi
Running several virus scans (all coming back clean)
Multiple scan and repairs of Warzone files (when I thought it was the issue)
Running DDU and a clean install of the G
A full wipe and reinstall of windows 10.

I even paid for a tech to come to my house and have a look at it for an hour. The result was “clean up your apps and if that doesn’t work reimage windows”. He was convinced it wasn’t a hardware issue at all after spending an hour on my pc.

To be fair after I reinstalled windows it worked just fine for a week of daily use but the issue has just happened again tonight and I’m at a complete loss…

Sorry for the long post but I tried to be as informative as possible and I appreciate it a lot if you read it all!
 
Last edited by a moderator:
Jun 9, 2021
3
0
10
0
brand and model of the psu?
I’m not very well versed in terms of building and parts for pc hence buying a pre built. Do I have to open my case to check that? And if you did know what psu I had how would that help? (Not being rude just curious) the PC has worked perfectly for a full year until this point, is it common for certain psu to start failing after that period of time?
 

ASK THE COMMUNITY

TRENDING THREADS