[SOLVED] Random BSoD on Ryzen 1600 even after changing mobo and power supply.

Sep 6, 2020
6
0
10
0
PC Specs
CPU: Ryzen 1600
Motherboard: Aorus B450 M
GPU: GTX 1060 6GB
RAM: Corsair Vengence 2400 2x8gb
PSU: CoolerMaster 650
SSD: 240gb gigbyte
HDD: 1 TB barracuda

I previously had Gigabyte b450m ds3h, thought this was the problem and replaced it with B450M Aorus. Also had a gigabyte 450 PSU, replaced it with Cooler Master 650, thinking that it was a power supply issue. I am still regularly getting BSOD, mostly on system idle, while browsing. The system runs for hours while gaming but when doing day to day tasks, gives BSODs.

I have checked event viewer, always shows kernal 41 error. On BSOD screen it is always stuck at 0% with message CRITICAL_PROCESS_DIED.

I have sent my graphics twice for repair as well. Still happens. I have not overclocked anything, BIOS settings are default. This PC has been driving me crazy for the past two years.
 
Sep 6, 2020
6
0
10
0
I have already run memtest86, it passed all tests(both rams together). I have not tested individually. I assumed that if it passed all test together than rams were all right. Is this wrong? Should I test individually as well?
 
Sep 6, 2020
6
0
10
0
I am currently testing the build with a new graphics card(1660 super). I will leave it for 24 hours to check if it crashes again.
 
When you switched out your motherboard did you reinstall windows clean because you really should if you didn’t and this could be the cause of your problems and it may mean the windows was the issue not your motherboard
 
Sep 6, 2020
6
0
10
0
When you switched out your motherboard did you reinstall windows clean because you really should if you didn’t and this could be the cause of your problems and it may mean the windows was the issue not your motherboard
Yes Mandark, I have performed a fresh Win 10 2004 install after switching the motherboard.
 

ASK THE COMMUNITY