[SOLVED] Random buzzing sound, black screen, and CPU debug light on ?

May 24, 2022
4
0
10
0
Hello, I am having this problem where my pc is randomly having weird buzzing sound when im wearing my headphones. Also, my pc is randomly having black screen and whenever the black screen will occur, the screen will freeze first then it produces a weird buzzing sound then the black screen will appear. Whenever the black screen occurs, my monitor shows no signal display. The lights of my keyboard and mouse also shuts off when this happened but the lights and fans of my pc is still on. Lastly, everytime this problem occured the EZ Debug light of the CPU in my mobo is turning on. So I guess the CPU may be the culprit but I would like to know if someone is also experiencing this and if there are possible solution for this problem.

Specs:

Ryzen 5 2600

MSI B450 Mortar Max

Gigabyte Rx570

Kingston Fury 2x8 16gb 3200mhz

be quiet! Straight Power 10 500w gold

2pcs m.2 ssd (WD Black and Kingston NV1)

Fixes that I've tried:

- Changed the motherboard

- Changed the rams

- Changed the GPU to a same model but different brand

- Disabled the global c state in the bios since I've read a post where we have similar issues and it is said that it fixed their pc by doing that.

- Changed my power plan to Ultimate Performance

- Reseated parts of the PC (CPU, RAM, cmos batt)
 
You probably got something going wrong with the motherboard

Also if you didn’t swap out the exact same parts you will have to reinstall windows with the motherboard swap

While it is possible it’s the CPU those kind of failures are extremely rare
 
May 24, 2022
4
0
10
0
You probably got something going wrong with the motherboard

Also if you didn’t swap out the exact same parts you will have to reinstall windows with the motherboard swap

While it is possible it’s the CPU those kind of failures are extremely rare
The problems already occurred before I swap my motherboard so I guess that it is not the problem.
I also check other forums that has similar problems as mine and I noticed that many of them are also using ryzen 5 2600 and amd CPUs
 
what mobo did you swap from and to? i need model numbers. if they were not the exact same then you most likely would have issues with windows doing that hang up with audio and lockup if you did not clean install windows

if that is not the case and they were identicle then you can rule out mobo

you may need a bios update though in this case
 
May 24, 2022
4
0
10
0
what mobo did you swap from and to? i need model numbers. if they were not the exact same then you most likely would have issues with windows doing that hang up with audio and lockup if you did not clean install windows

if that is not the case and they were identicle then you can rule out mobo

you may need a bios update though in this case
They were both MSI B450. From MSI B450M -A PRO MAX, to MSI B450 MORTAR MAX. I dont think that it has something to do with windows because I am experiencing the same issue from my first motherboard. I am also thinking about updating the bios but do you think it can be fixed? Because I think there are no compatibility issues with my mobo and 2nd gen ryzens
 

ASK THE COMMUNITY