Question Random crashes, resolution changes and unresponsive applications

Dec 3, 2021
4
0
10
0
Specs are
5900x
3080ti
32gb 3200mhz ram
1tb SSD with 650gb spare
1000w psu

Windows 10 Pro
Bios version: American Megatrends inc. 4021
SM BIOS verision: 3.3
Bios mode: Legacy
Windows Version: 10.0.19043

So I've had my pc for around 2 months now. I've never encountered any issues with it until I would say last week. It has been flawless up until then. I mainly use it for gaming. Warzone, arma 3, Forza, battlefield. Its run all those games in 4k at max settings perfectly fine. Zero issues. However recently in the beginning of this week I had a random resolution change when I turned my pc on. The aspect ratio and resolution were completely different from 4k to what looked to be 720p at the most. I then got an error message with the blue screen and white texts along the lines windows has encountered an error giving two options restart or advanced something. I restarted and everything was back to normal, continued using my pc as normal and gamed for a few hours perfectly fine.

The next day I went to turn my pc on it booted fine everything looked normal was running fine but when I went to open Eu4 it was unresponsive. I then went to launch it from start menu and in folder but it was still unresponsive nothing would happen when I tried to open it. I tried opening my other steam games and same issue, wouldn't open. I tried opening steam and that wouldn't open either. However non steam games worked fine. Everything else ran as normal. I tried a restart and that solved the problem steam opened as normal and Eu4 launched fine. However after an hour or two playing the screen randomly went black and crashed to desktop, but the game still showed as running in the task bar and task menu but wouldn't open when I clicked on it, audio was still on from the game also. I ended task from task manager and opened again but this time the game was extremely lagging and slow which is strange since my specs are more than capable enough to run without lag etc and other more intensive game have never given me this issue before. I then went to check my system settings but certain applications wouldn't open, display settings in Windows would not open neither would Nvidia control panel.

I restarted the pc and the system was working fine display settings and Nvidia control panel would open fine however I tried opening steam again but the same steam issue that happened the previous day happened again, steam and steam games unresponsive. However this time I went into task manager and ended steam tasks that were running and that solved the issue steam opened fine after that and the games would run. Eu4 worked as normal also.

Today I went to play Eu4 again this time upon booting up everything was fine and it launched like normal no issues. However again 2-3 hours in it crashed to desktop like before. I closed it from task manager and then went to check my drivers. All my drivers are up to date. I went to java configuration to check for update but as soon as I clicked on update the system crashed and I got the same resolution change error I experienced a few days before. A restart again solved the problem but every time I would try to update java from the java confug app it would crash again.

The most strange thing is, I've never had any issues like this before. Its only after Eu4 crashed did the other parts of my system that normally run fine start to play up. Again after a restart things are normally back to the way they should be. But if I play Eu4 and it crashes it's like something else will play up also.

I'm suspecting it may be a driver related issue because of the random resolution change. I highly doubt it's hardware related as all other games run fine playing on max settings for hours.

Any idea what the cause of the issue is???
 

ASK THE COMMUNITY