[SOLVED] Random Crashes while playing Games

apalace

Distinguished
Feb 11, 2014
100
0
18,690
2
My Specs:
MB: Asus Rog Strix B550-E Gaming / CPU: AMD Ryzen 5900X / Cooler: Noctua NH-D15S / PSU: Corsair RM850 (2021), RM Series, 850 Watt 80 Plus / RAM: Corsair Vengeance RGB PRO 16GB (2x8GB) DDR4 3200MHz (CMW16GX4M2C3200C16W) / ASUS TUF GeForce RTX 3070 TI

At first I faced some random self-restarts even while in idle, in a sudden the system restarts by itself.
I searched in the internet for similar issues and found that many who use Zen3 CPUs face such issues, and found a solution by changing some settings in Bios like: Power Supply Idle Control -> Typical Current Idle
And other fee tweeks for the CPU to be stable. This random boot is gone.

Now I face another problem, which is crashes during playing games.
Sometimes I play for hours with no issue, but then crashes, and sometimes the crash occurred after 15 minutes..
I have never faced such issues before in my old builds.
I have read some solutions for this issue also, like increasing the Volts of my Rams, and do some tweaks with it.
HEre I have no idea what should I increase and how much, like the timings or only the volt (someone suggested increasing the volt to 1.42 )
So can someone please help me, who experienced the same issue and has similar setup what timings/volts should I type in Bios and musst the DOCP be disabled or set on Manual or Auto?

Appreciate any comment!
 
Last edited:

apalace

Distinguished
Feb 11, 2014
100
0
18,690
2
Yes I confirm here that this is the right solution to stop crashes/reboots of the Ryzen 5000 series CPU:

in Bios change the following:
Precision Boost Overdrive -> Manual
EDC limit = 200A
Curve optimizer = +4 ( test it, when the issue continues, go up for +6, then test it if crashes continue go up to +8)

I tested it for several days now and many hours playing games, no single crash. At least this is the solution till they release a Bios firmware that fixes it.

Thank you drivinfast247 and RARRAF for your comments on the thread trying to help.
 
Hi there DOCP is asus overclocked so hole system and works most of the time but if you are having issues turn it off.
asus "armoury crate" might find some drivers for the moutherboard that are not up to date and could help normally the last one on asus driver page.
 

apalace

Distinguished
Feb 11, 2014
100
0
18,690
2
Thanks for replying!
Actually everything is up-to-date ,bios, drivers everything.
And the DOCP was turned off by default, it was in AUTO and I didn't change it.
So should I turn it in? Then should I change the RAM volt or what exactly?
 

apalace

Distinguished
Feb 11, 2014
100
0
18,690
2
Enable D.O.C.P. Make sure RAM is installed in slots a2-b2
Thank you for your reply!
The RAMs are indeed in their places A2 and B2
I increased the voltage to 1.42 (it was 1.35) as someone in other forum suggested, and tested it with D.O.C.P enabled as you mentioned, it seems the crashes are gone.
I played a game for over 5 hours, and didn't experience any crash or issue.

Thanks again for your advice!
 

apalace

Distinguished
Feb 11, 2014
100
0
18,690
2
UPDATE:

It seems the issue came back..
It did crash while playing a game, and today the PC restarted by itself while playing a game.
I admit that I can spend playing a game for some hours before it crashed or restarted, but still something must be wrong here.

I appreciate any help.
Here is the error report off the Event Viewer (Windows Logs -> Applications): https://ibb.co/3pFsbyB
and this is the log file off the system error : https://ibb.co/b3YhLsW

Thanks for any comment.
 
Last edited:
UPDATE:

It seems the issue came back..
It did crash while playing a game, and today the PC restarted by itself while playing a game.
I admit that I can spend playing a game for some hours before it crashed or restarted, but still something must be wrong here.

I appreciate any help.
Here is the error report off the Event Viewer (Windows Logs -> Applications): https://ibb.co/3pFsbyB
and this is the log file off the system error : https://ibb.co/b3YhLsW

Thanks for any comment.
Reset BIOS to defaults. Touch nothing.

Use PC and report any issues.

Are you on latest chipset driver?
 

apalace

Distinguished
Feb 11, 2014
100
0
18,690
2
Reset BIOS to defaults. Touch nothing.

Use PC and report any issues.

Are you on latest chipset driver?
Yep I am on latest Chip driver.
I changed now the following in Bios:
"Precision Boost Overdrive" -> Manual.
EDC limit = 200A.
Curve optimizer = +6.
I will test the result for 2 or 3 days, if the issue occur I will reset the bios back to default and see how it goes.

They say that the Zen3 CPU architecture somehow isn't good optimized by the MoBos ,and it is working better when on high load, I quote what one of them said:
"The problem is not overheating, the problem is inability of a given crappy CPU to work stable at a given frequency with a given voltage. (just the same as if you undervolt it too much). The larger the frequency, the more chance of a BSOD to occur. The fully all-core loaded CPU works at LESSER frequences to stay within the TDP. But when you stop your burn-in and start to watch a video, just one or two cores (pre-heated by the previous burn-in) work, but they work at the MAXIMUM frequences. And - say Hi to a BSOD or reboot. "

And I think he is right, because the crash happens mostly when I am in a Lobby of the game and not while too much loads and heat.
 

apalace

Distinguished
Feb 11, 2014
100
0
18,690
2
Yes I confirm here that this is the right solution to stop crashes/reboots of the Ryzen 5000 series CPU:

in Bios change the following:
Precision Boost Overdrive -> Manual
EDC limit = 200A
Curve optimizer = +4 ( test it, when the issue continues, go up for +6, then test it if crashes continue go up to +8)

I tested it for several days now and many hours playing games, no single crash. At least this is the solution till they release a Bios firmware that fixes it.

Thank you drivinfast247 and RARRAF for your comments on the thread trying to help.
 

ASK THE COMMUNITY

TRENDING THREADS