Question Random Crashes with M.2 SSD installed

Jun 10, 2019
2
0
10
0
I've tried two different, brand new, NVMe SSDs in the M.2 slot, and both work fine for several minutes, sometimes hours, but eventually trigger a random reboot. I'm only using the SSD as a spare data drive, and Windows is still on the original drive, but it reboots just for having the M.2 SSD in my MOBO. Once I remove it from my MOBO, then everything runs fine again.

The crashes are not happening under any particular load, sometimes without even a keypress. The whole system just goes black and reboots, and sometimes the reboot fails the first time, and I have to power off / on.

Any ideas on how to get the M.2 SSD working?


MBD: Gigabyte GA-AX370M-DS3H-CF
CPU: AMD Ryzen 7 2700X
GPU: Nvidia RTX 2070
SSD: Adata XPG SX8200 Pro NVMe PCIe M.2 1TB
SSD: Gigabyte SSD 240GB
HDD: Seagate Barracuda 2TB (2016)
RAM: Adata DDR4 2400 2OZ 2x8GB
PSU: 600 Watt
 

Grobe

Distinguished
How long time does it normally take before this sudden shutdown occur?

Have you done any changes prior to this issue?
Have you updated HW while kept the same Windows installation ?

- leave this part until it is clear wheter Windows are installed from scratch or transfered from another hw setup (I wrote this first and then I came to think about the WIndows part above):
I suggest start with the easiest part - to check if there are any problems to RAM. Get Memtest86+ (also included in UBCD toolkit) and let it run for some hours - preferably overnight - to ensure there is nothing bad with your RAM.

Second : Read through your motherboard manual and make sure there are no conflict about having the HDD connected to the current sata connector.
In not sure, you could always just try to swap sata connector until the system behaves more stable (if that is the initilal cause of the issue).

Then if nothing seems to help, you need to find out if it is related to hardware or software (driver).
To do that - I suggest you got a Linux Live-CD to test the stability over time.
 
Jun 10, 2019
2
0
10
0
At first it seemed to take a couple hours before it shut down, but then sometimes it would shut down within minutes.

I was having even when I kept Windows running from a separate drive, and using the new M.2 drive as an extra storage drive.

Today I tried changing the mode in BIOS from "Legacy Only" to "UEFI Only" and the computer worked for many hours, but then it still eventually crashed as usual.

I'll try the Memory Test tonight. Thanks for your suggestions.
 

ASK THE COMMUNITY