Question Random FPS drops ?

Sep 18, 2022
12
0
10
0
Performance issue

Yo, not sure why but I randomly get hard FPS drops when playing demanding games like AC Odyssey or Marvel Guardians Of The Galaxy, etc. Like the game runs fine for a while but out of nowhere my FPS rockets down to like 40 FPS and hard stutters even trying to reduce the quality does nothing. But one thing that fixes that issue is tabbing out then back in, but playing for a bit longer the problem happens again. Maybe not all the time but that usually fixes it. It can even fix it self after awhile but eventually come back.Not sure if it's my CPU usage at 100% and GPU at 97% because when I tab out I see that the usage goes down but slowly becomes higher. But when it comes to like GTA V, R6, and more easygoing games they run super well. I've tried multiple stuff but just can't seem to fix it. Thank You.

My specs are:

GPU: Gigabyte Geforce RTX 3070 8GB EAGLE 2.0

CPU: AMD Ryzen 5 5600X

SSD: Samsung MZVLB256HAHQ-000L7 256GB

HDD: Seagate Barracuda Compute 1TB / 64MB /

7200 RPM / ST1000DM010

RAM: Corsair Vengeance LED DDR4 3200 C16 2x8G

User benchmark Test:
https://www.userbenchmark.com/UserRun/55346278
also not sure why my GPU doesn't show up.
 
Last edited:
Sep 18, 2022
12
0
10
0
I can try running it later but I’m pretty sure it is as i can see it in Speccy and being able to play other games fine with good FPS
 
Sep 18, 2022
12
0
10
0
Okay, i am very confused here. I will now post a video on what the problem is. I still am not sure what is causing this lol.
 
That looks like stutters from hard drive access.
If you play your games at max quality and draw distance new textures/skins etc will have to be loaded into memory then the video card.
Very slow process.
Try turning down draw distance to see if it helps . Not eliminate but reduce stutters.
 
Sep 18, 2022
12
0
10
0
i mean I’m not even running with max settings im running High/Med settings and I’ve tried to lower graphics while it’s happening but of no use because it still stutters and lags.
 
Do you have enough space to load one of the games that skips to your SSD?
Another cause could be windows 11.
There is a bug in older bios that caused unusuall high TPM (Trusted platform module or fTPM on amd platforms.
See if you motherboard has an update for this with a bios update.

First make sure this is your motherboard model and revision.
 
Sep 18, 2022
12
0
10
0
I have not overclocked my GPU. I’ll post the first page of GPU-Z when i come home. But i mostly believe it could be Cryptojacking as i have searched, but still not sure why I can’t detect it with MalwareBytes.
 
Sep 18, 2022
12
0
10
0
It’s funny because when i’m in-game and playing MSI Afterburner is showing 97% GPU and 100% CPU but whenever i open Task Manager as seen on the clips I’ve linked, they instantly go back to normal usage. Very confusing.
 
Sep 18, 2022
12
0
10
0
It only shows the game and other normal applications being used. I’ll post a picture of task manager while I’m playing.
 
Sep 18, 2022
12
0
10
0
Hello, sorry for not updating but I’m pretty sure i fixed the issue. It seems that it was actually a virus after all called Cryptojacking. Thank you guys for the help. Will update incase it happens again.
 

ASK THE COMMUNITY

TRENDING THREADS