Random frame drops ( not always the case )

ojv.g

Commendable
Jan 23, 2018
48
0
1,540
1
Hi,
im running a i3-7100 3.9mhz, gigabyte geforce gtx 1050 2g and as a motherboard i got a asus prime b250m-a. i got 4gb ddr4 2400mhz ram stick and using a ( what i think) fairly old hdd thats about 2-3 years old. everything from cpu/gpu/ram/motherboard is bought very recently. only the hdd is a old part of the pc together with the psu/case but that doesnt matter to much. ive downloaded overwatch and world of warcraft and what i noticed is is when i run overwatch at 1080p low setings 75% render i sometimes get these weird frame drops that come out of nowhere. my pc is perfectly able to run these settings but what i do know is that i probably need atleast 8gb ram. even thought 4gb is enough what i notice is that my disk usage when i open a app or as i said playing games go to 99-100% a lot. my cpu is good temperature aswell as the gpu and the ram usage is okey its around 70-80% its on the edge but yeah its doable. do u know why my pc has these weird frame drops randomly. if any of you are able to help me or give me the right tips i would highly appreciate that. thank you. :D

note: i manually downloaded motherboard drivers and since im an idiot with pc's i might've skipped something worth downloading. but this wouldn't cause frame drops if am correct? forgot to mention that the frame drops are from 120-150 fps to 30-50 fps wich causes my game to stutter and freeze for 1-2 seconds.
 
ive downloaded overwatch and world of warcraft and what i noticed is is when i run overwatch at 1080p low setings 75% render i sometimes get these weird frame drops that come out of nowhere.
Where did you download the games from? fps dropping is the PC ( hardware and software) problem.
 
I have other questions for you.
1) Do you reinstall the windows ? because you only said the HDD was old, but don't say you reinstall the OS yes or not. If you did not, that may cause problem too.
2) May test the HDD with HD Tune http://www.hdtune.com/ If it is true, the disk usage was going up to 99-100%, that it will cause the problem too, even the PC will freeze too.
3) What PSU did you have?
4) I don't know what other programs you had, sometime if more programs run in background, it will cause the fps drops.
5) Yes, not enough RAM may also become a problem too.
 

ojv.g

Commendable
Jan 23, 2018
48
0
1,540
1
1. Well i am not quite sure if i reinstalled windows because here's the thing. I installed a new cpu/gpu/motherboard as i said and when i started my pc it didn't start up immediantly, but gave me some windows question like time, updates, connecting stuff etc that being said when it eventually started up and was able to run my pc my disk was empty completly empty and i had to reactivate my windows key. the code was luckily on the side of my pc case so got lucky there. so i guess i reinstalled windows it took about 10-15 min max for everything to be done.

2. was about to download hddtune but it says free version is not avalaible for win10. also found out that when i open apps disk usage goes up to 99-100% not everytime but most of the times. opening apps or games and when its loaded it drops down again to 0-5-20%. i did aswell notice that if am playing for example world of warcraft my ram usage is always above 80-85% and even hitting 92% 3.6/3.9gb used when using browser while game is open. at this current moment having only this site open and world of warcft i am at 95% currently 3.7/3.9gb used. mayybe this could explain aswell why my game stutters sometimes or freezes for a second, having the game open and this website my disk usage is stable 20-25% its only when i open apps or games or very rarely that it has a spike to 99% while doing something and not opening stuff. if i have this tab open and go into my game its really stuttering more than if i dont have my browser open. my cpu currently 5% and gpu 2% only thing thats really high atm is my ram usage.

3. i have a xilence performance c xp400, 400watt voeding https://www.alternate.be/xilence/performance-c-xp400-400-watt-voeding/html/product/1165307 not super super good but is good enough to hold this for a while untill i can buy a new one.

4. as i said in (1.) my disk was empty when it fully started up i never have any programs running in the back. so this pc is really clean compared to using programs and stuff. i can play world of warcraft fine aswell as overwatch with sometimes stutter small freezes but if i stand in a city where theres 50-70+ players it takes a while to load all of them and it can be hard for my fps to handle ussually takes a while untill everything is loaded.

5. yeah like i said my ram is always 80-85+ when im only playing 1 game without anything open. once i open a browser and for example go to the forums my ram goes to 90+ 95-97 being tops. if i still have my browser open and i go back into my game, the game is really really laggy as in stutters/freezes but more frequently. could it be that if games require to much of my ram wich it cant hold that it switches to disk?


note: i manually downloaded my own motherboard drivers and gpu drivers. gpu drivers were really easy to download just follow and click, but for motherboard drivers i got confused for a bit as in if i downloaded for example chipset driver. i had to unpack the thing in my folder so i did. when it was unpacked there are like 2 folders in the driver and multiple asussetup options to actually install them so i just pressed install on the one that i found most logic and that was in the main folder. but i dont think thats causing the problem since i can run games good its just when theres to many things to load.


thank you for putting your'e time into this. i really appreciate it!
 
1) From what you said, you did not clean reinstall the win10, and the old drivers from the old PC may cause the problem.
2) The PSU is the problem too, because the gtx1050 will require the 350 W PSU with 17Amp on the +12V rail at least. But your PSU has only 15A.
3) If you have other HDD, try it.
4) Yes, you need more RAM.
 

ojv.g

Commendable
Jan 23, 2018
48
0
1,540
1
so i can do a reinstall of windows in windows options right?
i dont understand how old drivers could cause this problem when my disk was completly empty when i started pc
 

ASK THE COMMUNITY

TRENDING THREADS