[SOLVED] Random lock ups

Oct 24, 2019
2
0
10
0
So my pc just random "locks" my mouse and keyboard when i plug in my sensor from my oculus rift into my pc, before i was using a USB 2.0 cable for one of them but i recently switched to a 3.0 cable to the second one. whenever i plug in the usb 3.0 cable my mouse and keyboard freezes for a few seconds and then works normal again and it keeps doing that until i plug out the sensor... and the pc begins to completely f-up like the HDMI on my graphics card says it doesnt work. i cant even do the setup for the oculus rift without it fucking up. Can someone help me diagnose the problem. is it the power supply which doesnt supply enough power to the whole system? Right now i have tried re-installing the oculus software which didnt work. Im thinking myself its the power supply thats is really shit, but i dont want to take the chance and buy an expensive power supply just to find out that its not the problem, also im broke so i dont have money for a good power supply right now

My specs:
CPU: i7 2700K (i think i can't remember
GPU: GTX 1070
RAM: 16 Gigs DDR3
MOBO: MSI something idk
PSU: unknown and i think it supplies around 400-500 watts i have abolutely no idea
I have no idea because its a pre-build system i got from my big brother...
 
Last edited:
Honestly you may be on to something with the power supply. Normally i would point to this behavior as being a USB controller issue but the baseline computer you have excluding peripherals draws around 488 watts so adding a rift even though it likely does not draw more than 5-10 watts may be enough to push you over the edge
 
Reactions: rasm485q
Honestly you may be on to something with the power supply. Normally i would point to this behavior as being a USB controller issue but the baseline computer you have excluding peripherals draws around 488 watts so adding a rift even though it likely does not draw more than 5-10 watts may be enough to push you over the edge
 
Reactions: rasm485q
Oct 24, 2019
2
0
10
0
Honestly you may be on to something with the power supply. Normally i would point to this behavior as being a USB controller issue but the baseline computer you have excluding peripherals draws around 488 watts so adding a rift even though it likely does not draw more than 5-10 watts may be enough to push you over the edge
so youre thinking its a power supply issue? Thanks for the help!! One last question, what power supply do you think i should get if my system draws around 488 watts? i was thinking a 650 or a 700 watt, that is actually branded and good
 
Sorry for the long wait i was on a hunting trip. A good rule of thumb is a 25-30% overhead so if you draw 500W id go for a 650-750W psu. Make sure you buy from a reputable brand. I would suggest EVGA, Cooler Master, Corsair, or SeaSonic
 
Reactions: rasm485q

ASK THE COMMUNITY