Question Random Pc freeze and/or restart

Nov 17, 2019
6
0
10
0
Hi, I have been dealing with random PC freezes for months on end. I have had my pc for about 9 months now. These freezes and/or restarts started happening used to happen about twice a week and now it is becoming an every day occurrence. These freezes happen randomly at pretty much ANY time. It can happen after an hour of gaming, or even thirty seconds after I start a game. It has come to the point that my computer will freeze while booting up or on the home screen. After a freeze, it either randomly restarts or stays frozen. When it stays frozen, I have to force restart the pc. After the restart, it either boots up normally or sometimes to a blue screen of death. Sometimes it takes over three times for the PC to post to the monitor. When it does not, I get a no signal from the monitor.
My specs:
CPU: Ryzen 5 1600
MOBO: ASUS B450M-A/CSM
RAM: G Skill Ripjaws V 8GB 2 x 4 ram (red)
PSU: EVGA 500 watt 80+ white ATX
HDD: 1TB Westen Digital
GPU: GIGABYTE NVIDIA GTX 1060 3GB WINDFORCE OC
CASE: Thermaltake Versa H18 Tempered Glass
Fans: 2 Thermaltake LED fans

Here are some things I have tried so far:
  1. Using DDU to uninstall and reinstall drivers. (Had to do this multiple times as drivers continuously refused to install). I then updated my Nvidia drivers.
  2. Replacing my HDMI cable
  3. Checking inputs: I have noticed that a couple of inputs from my MOBO have some sort of input lag. I am not sure if this is related to the freezing.
  4. Updating windows
  5. Updating NVIDIA a drivers yesterday. It took two tries as the PC froze while trying to update the drivers.
  6. Using windows to check ram. No problems were found
  7. Also using windows to clean files. Some files were corrupted but gave me an error code saying files were not able to be cleaned. It gave no specific ways to fix this.
  8. Updating BIOS. This was the last thing I tried so far. Once I rebooted it after another freeze, I went into bios. Before I could click on anything, the PC froze.

And this brings me to now. The PC just booted after 10 tries of restarting it. I have no idea on what is going on and what may be the problem. GPU fans stopped when the PC froze but this may have been due to it not being on load. I really don’t know what to do from here. Any help would be appreciated!!!
 
Nov 17, 2019
6
0
10
0
So, everything is running at stock speeds. I calculated everything before building on Newegg and figured it was about 250 watts, so I bought a 500 watt power supply. I figured that would be enough unless there is some other reason on why that might not be enough.
 

COLGeek

Cybernaut
Moderator
Not all PSUs are created equally. Some are much better than others. Also, power calculators can simply be wrong.

You seem to be having lots of power related issues, often caused by an under-powered PSU.

When you installed Windows, did you also install the AMD chipset drivers (downloaded directly from AMD)?

This would be a better choice for PSU than what you currently have:

https://www.newegg.com/corsair-cx-series-cx550m-550w/p/N82E16817139147

I prefer Seasonic PSUs, like this one:

https://www.newegg.com/seasonic-prime-ultra-gold-ssr-550gd2-550w/p/N82E16817151207
 
Nov 17, 2019
6
0
10
0
I didn’t install the chipset drivers but I’ll get a better power supply then if needed. I thought an EVGA 500 watt would be fine hahaha.
 

COLGeek

Cybernaut
Moderator
BTW, are you attempting to overclock anything (CPU, GPU, memory)? If so, revert to stock speeds.

Also, do you know what speed your memory is set to in your BIOS? If anything above 2133, lower to 2133.
 

ASK THE COMMUNITY

TRENDING THREADS