Question Random PC reboots/freezes ?

lukcash7

Honorable
Mar 12, 2018
19
1
10,515
Hello,

Approximately 2 months ago I have built myself a new gaming PC. Since day one I've had problems with this system that are still ongoing, hence why I'm creating this thread to seek help from someone more experienced. Progressively it got worse, the freezes came first then the reboots followed after. Now it's a combination of two. 95% of the time the PC reboots, freezes are not as common but when it does I have to reboot anyway. It's something I've never experienced before and I'm kind of lost and not sure how to troubleshoot this. I'm worried one of the parts could be faulty.

I'm currently stuck on a black screen. No BIOS start up screen. However, when I turn off the PC for a 30 min and leave it alone and boot it up again I will get this:

"New CPU installed, fTPM/PSP NV corrupted or fTPM/PSP NV structure changed."

I always press N and continued to system boot. I can get past the Windows login screen, often times even use the PC for a long time without it forcing a reboot on me. I'm talking about like 8 hours of two days in a row without any signs of problems but then it comes back again.

I've done benchmarks on the PC like CPU burner + Heaven Benchmark. PC works fine under heavy load.

After the PC forces a reboot or freezes and I continuously try to get it to boot up after multiple forced crashes, the screen I spoke of above is normally what I get and the reboots get more frequent. Sometimes so frequent I won't get past the BIOS boot up menu. This is what worries me because this is where I think it may be a hardware issue.

I don't know how much it will help but I've taken a picture of errors in Event Viewer that pop up at the start of boot up: View: https://imgur.com/a/9iWwOcf
(sorry for the bad quality)

Again, if anyone can help in any way I would really appreciate it. Thank you!!!

Troubleshooting I've tried:

  • One RAM stick
  • Unplugging GPU from power and connected display port to mobo
  • Stress tests of both CPU and GPU

Computer specs:

Mobo: ASUS TUF GAMING B650-PLUS WIFI
GPU: 7900 XT
CPU: Ryzen 7800X3D
RAM: Crucial 16GB DDR5-4800 (two sticks)
PSU: Thermaltake 850W
 

lukcash7

Honorable
Mar 12, 2018
19
1
10,515
this article seems to cover the errors that you are experiencing.

I have disabled the fTPM in BIOS as well as followed other steps but the problem still appears.

I played around in Google Chrome for 2 minutes and the PC froze. Black screen, only cursor visible. Second time it just rebooted, third time bluescreen. After bluescreen it keeps on repeatedly rebooting itself in the BIOS startup screen.

Motherboard flashes orange for 1 sec, red for 2 sec, white for 1 sec and then it goes green 3 sec. After that all lights dissapear and then the PC reboots itself and does the same thing over and over again.
 
Last edited:

lukcash7

Honorable
Mar 12, 2018
19
1
10,515
Thank you for your time! 😀

I've seen some posts online saying that some BIOS update versions can be problematic for B650 motherboards. I updated it 2 months ago but I can see that there is a new version online so I will try to update it once more and see if the issues will go away.
 
Last edited:
  • Like
Reactions: Tac 25

lukcash7

Honorable
Mar 12, 2018
19
1
10,515
I have replaced my current motherboard with ASRock B650 LiveMixer. To my surprise when launching the PC the CPU LED is on and the DRAM LED is constantly flashing.

No BIOS screen, fans spinning for an eternity. I think it's what I feared and my CPU is somehow faulty. I'm not sure how this could of happened because it was a new CPU that was somewhat functional before.
 

lukcash7

Honorable
Mar 12, 2018
19
1
10,515
Okay so I've bought another CPU, same as previously - I still get CPU LED on a motherboard along side with DRAM flashing constantly, no screen. I'm so close to giving up. I honestly don't know what's wrong.

Replaced mobo - still not working
Replaced CPU - still not working

What's going on with this PC, is it RAM now?