Random restarts on high load

VMord

Honorable
Apr 7, 2012
27
0
10,530
Hello Forum

I have recently finished my first build, and it usually works without a charm. However, lately, when i play BF3, my PC sometimes just restarts. My PC has only been doing this in the past few days, i had no problem during the first two weeks with playing Battlefield 3 (note that i play on ultra) Here are my specs:

Case: NZXT Apollo
Mobo: AsusP8z68-le
GPU: MSI Twin Frozr III 7850
CPU: i5-2500k
CPU fan: Cooler Master 212 Evo
HDD: Barracuda 7200.12 1TB
PSU: Corsair 650W
*Note that i also have two fans in my case

I don't think that this should be happening, isn't 650W more than enough to supply my build? And why is this first starting to happen now?

Any help would be very much appreciated
 
Solution
There you go. Thank you Asus!

If you didn't notice a power surge in your house at the same time (which a good PSU would protect your system from), you're probably dealing with a bad PSU.

I would exchange the PSU. Don't use it any longer or you might ruin the rest of your components. That model is a good model, but you just got a bad one.

VMord

Honorable
Apr 7, 2012
27
0
10,530

It just goes black screen, and on startup again it gives me an error saying something about the PSU
 

There's a clue for you. What does the error say about the PSU?

I once had a bad video card that would do what you're describing. I exchanged it for a new one and all was well.

Though if you're getting a message about the PSU, this might point to something else altogether.
 

VMord

Honorable
Apr 7, 2012
27
0
10,530


Okay, here's the error: "Power Supply surges detected during the previous power on. Asus Anti-surge was triggered to protect system from unstable psu"
 
There you go. Thank you Asus!

If you didn't notice a power surge in your house at the same time (which a good PSU would protect your system from), you're probably dealing with a bad PSU.

I would exchange the PSU. Don't use it any longer or you might ruin the rest of your components. That model is a good model, but you just got a bad one.
 
Solution

VMord

Honorable
Apr 7, 2012
27
0
10,530

THX! I have sent a message to Corsair Tech Support.
 

VMord

Honorable
Apr 7, 2012
27
0
10,530


Are you sure that the PSU is just not powerful enough for my rig?