Question Random restarts (specially when playing CS:GO)

Jan 17, 2020
1
0
10
0
Hey everyone.

My PC has been randomly restarting for around 2 months now. During all this time, it has shutdown I guess only twice when I was doing normal stuff, once or twice when I was playing BF1, once during Outlast 2, once during PES 2020 and once during Minecraft.

I never know when it's gonna restart, except when I go play CS:GO. It will restar FOR SURE if you play it. Sometimes it restarts at the beggining of a match, sometimes in the middle of it. One curious thing is that: if I'm playing CSGO and it restarts and then I'll go play BF1, it will work for hours. But if I go back to CS after it restarts, it will take just a few minutes until it restarts again.

So these are my components:
  • Aorus Z370 Gaming 5
  • Intel i7 8700
  • Corsair Vengeance LPX CL16 2x8GB
  • Corsair MP510 240GB
  • Seagate ST1000DM003 1TB
  • Cooler Master Masterliquid Lite 120
  • Gigabyte RX590 8GB (rev. 2)
  • EVGA 650W 100-N1-0650-L
What I've done so far:

  • Checked overheating, dirst/dust are not the problem
  • Updated all drivers
  • Checked disks with that Windows' disk verification tool and cmd
  • Checked Windows installations and even formated it
  • Checked for Malware
  • Reinstalled Antivirus (Kaspersky Total Sec.)
  • Disabled sleep mode
  • Disabled fast start up
  • Updated BIOS
  • Plugged PC directly into outlet
  • Replaced PSU cable
  • Cleaned RAM and RAM slots
  • Checked RAM for errors with that Windows tool
  • Stressed CPU/GPU/SSD for some minutes and it didn't shutdown
  • Cleaned everything (including PSU)
  • There's probably more I forgot to include
Some worth-knowing things:

1: I got the GPU/SSD/RAM some months ago, first they delivered the GPU only. I installed it and played CSGO for a weekend normally before they deliver the other parts on Monday. When I got the other parts, I had 24GB of RAM of which: 2x4GB 2666MHz Corsair Veng. LPX CL16 + 2x8GB 2400MHz Corsair Veng. LPX CL16. When the PC shutdown for the first time, the first thing I did was using only the new RAMs. It kept restarting so I tried using the older ones. Same thing.

2: Intel Turbo Boost is activated everytime. Even if I'm idle the CPU clock is between 4.3 - 4.6GHz. Now I set it to stay at 3.8GHz maximum.


Maybe the PSU got too much lazy after 2 years of easy work and now that it has to work more it can't handle it?

It's strange that this problem started after adding the new components, but that CS:GO thins is stranger.

I did everything I could. Now I ask you if there's anything else I could do BEFORE I take any parts to a specialist? Any tips? Why would CS be so affected by it?

The PSU is my main suspect. I'm afraid it could be the motherboard, please don't be it.


Thanks in advance for your support, guys.

Ah, I hope this can help:
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS