[SOLVED] Random Screen Flashing on a GTX 1050 Ti Low Profile

Codelyoko373

Honorable
Oct 28, 2013
255
0
10,790
4
I'm not sure if it's broken or something but for awhile now after having installed my GTX 1050 Ti, I've noticed that occasionally it'd cause my second monitor (Which is connected via DVI) to flash quickly to black and back. There doesn't seem to be any consistent cause for it though having something like google running on the second monitor while I'm possibly playing a game on my main monitor is when it normally happens. It does occasionally also happen with my main monitor (Connected via DP) but I've not seen a consistent setup for it yet.

It never really has bothered me that much as the screen would always come back. Though I recently just started playing the Witcher 3 and that game seems to freak my graphics card out. Seems to be that if I open something like the shop menu, the map, or when playing gwent, my main monitor (Which I'm playing the game on) will flash rapidly with a bunch of white lines running down the screen. It'll do this a couple of times before eventually breaking completely, with the monitor no longer receiving a signal, though my second monitor is fine. My main monitor also has speakers within it and you can hear a quick noise of static every time it'd flash. I never managed to get it to work again without having to restart the entire computer. I tried to recreate it and it's pretty easy to recreate, but also easy to stop if you quickly exit out of the game before it breaks.

Does anyone have an idea what could be happening? I imagine it's broken in someway but just to be sure, I thought I'd ask
 

Codelyoko373

Honorable
Oct 28, 2013
255
0
10,790
4
Ended up fixing it. It seems that it was due to the fact that my monitor was running at 60HZ instead of 144HZ (It's max). Not exactly sure why that was a cause but it's fixed now haha
 

ASK THE COMMUNITY

TRENDING THREADS