Question Razer Blade 15 Advanced (2019 model) is micro-stuttering on battery power ?

Oct 23, 2022
I bought a Razer Blade 15 Advanced on ebay a couple months ago and ive had this issue where when its unplugged, it microstutters all the time around every 15-20 seconds(this has been an issue since i bought it). It happens when im scrolling or watching youtube or doing anything at all. Ive gone through power settings and nvidia control panel and intel graphics command center and changed everything i thought might have an effect (i may have missed some things, but i dont know) and it still micro stutters.

This does not happen when its on mains power though. When its plugged in, everything works well with no stutters or lag. Ive tried other peoples solutions online which still dont work which is why i want to open my own thread since it may be something really specific. Just to note, all the drivers and windows are up to date. I read a small comment someone had about a hp spectre that was having a different issue but was stuttering and one of the responses was asking if it was a battery issue? If it is a battery issue does anyone know a good website to get good parts from? Any help will be appreciated.
Oct 23, 2022
Hi, thanks for the reply,
For Windows Power Plan:
I've changed wireless adapter settings to maximum performance on battery,
Intel (R) Graphics Power Plan to maximum performance on battery
PCI Express Link state power management to Off on battery
Processor performance core parking min cores to 100% on battery
Minimum processor state to 10% on battery
Maximum processor state to 100% on battery
Multimedia settings all to either performance bias or optimise video quality
And I've not changed any settings with battery

For Nvidia control panel, I've changed:
Image settings to "use advanced 3D image settings"
In "Manage 3D settings", I've changed preferred graphics processor to "high-performance Nvidia processor"
And in "Configure surround, PhysX" I've changed processor to "NVIDIA geforce RTX 2070 with Max-Q design" (I don't know what PhysX does but I tried it anyway)

In intel Graphics command center:
I've changed settings for power plan to maximum performance, display power saving technology to disable and panel self-refresh to disable (all on battery)
This is all I've changed on Intel Graphics Command Center.

As for anything else, I've tried updating all drivers for intel and Nvidia and windows update has all the optional stuff as well.

Hope this helps,