Razer Imperator Issue

NewUser7

Distinguished
Jan 16, 2012
3
0
18,510
0
Hello,

I own a Razer Imperator 2012 gaming mouse. When I play FPS games, sometimes the mouse cursor moves fast by it self and after lifting the mouse off from the mouse pad, it goes back to normal. I'd like to know what is causing this issue and how can I stop it from happening again?

My DPI is at 900, acceleration is off, on the fly sensitivity is off, independent X-Y sensitivity is off, surface calibration is on, lift on rage is at auto and polling rate is at 500Hz. Driver version is 2.02 and Firmware version is 1.05.

Sorry If posted on the wrong forum. Thank you for your time.
 

blk_blgria

Honorable
Jan 24, 2013
1
0
10,510
0


I am having similar problems with my Imperator, though mine is more erratic. I think it is a failure of the hardware, not something you can hope to fix with software. I have tried everything, including talking with Razer. No help.
 

inzone

Champion
Moderator
Mar 12, 2011
14,971
0
55,160
1,326
There are some posts floating around that I have seen and it points to Razers Synapse 2.0 as being the problem and though you have 2.02 it's still 2.0 and that could be the issue. Have you tried different settings , like 1000hz poling rate or a higher Dpi ?
 

Valentin Moldovan

Honorable
Apr 26, 2013
1
0
10,510
0


same problem,
It cant be software problem coes I didnt had this prblme last year.
I tried to update the things arent solved...
Razer sks I ll move on to others mice more fiable.
 

Similar threads