Question Razer Kraken Ultimate

May 28, 2020
4
0
10
0
Hello. I've just bought a new pair of Razer headphones Kraken Ultimate and I've noticed that the sound is disrputive or like lagging/freezing. I'm not sure if this is beacuse of the headphones or beacuse of my rigg and that's what I'm trying to find out. Using them on normal or THX Spatial is kinda the same, I've noticed the issue playing CS:GO, where I was spamming the M4 while the sound was doing this (lagging/freezing/disrputive). Not sure how to call it.

Can anyone help me find out if that's beacuse of the headphones or beacuse of my rig, please?
I run Windows7 Ultimate x64 on a Asus Z77 Sabertooth (Which by the way, I have another thread opened for this one, I think it's faulty but no solid answers yet) with an 750W PSU *8GB Ram/3GB GDDR5 Radeon R9 200 GPU).

Before I had Steelseries 650 but it came with broken sound card from factory so I had to change them but with those I had no problem playing/listening music. And before that I had some HyperX but those were really bad quality, but still, no similar problems. Sometimes I miss some windows sounds, like clicking the volume bar many times or starting a faceit game (no start sound), but just from time to time.... Youtube runs good when I'm only on Chrome tho and no CSGO open.
 
Last edited:
Hello. I've just bought a new pair of Razer headphones Kraken Ultimate and I've noticed that the sound is disrputive or like lagging/freezing. I'm not sure if this is beacuse of the headphones or beacuse of my rigg and that's what I'm trying to find out. Using them on normal or THX Spatial is kinda the same, I've noticed the issue playing CS:GO, where I was spamming the M4 while the sound was doing this (lagging/freezing/disrputive). Not sure how to call it.

Can anyone help me find out if that's beacuse of the headphones or beacuse of my rig, please?
I run Windows7 Ultimate x64 on a Asus Z77 Sabertooth (Which by the way, I have another thread opened for this one, I think it's faulty but no solid answers yet) with an 750W PSU *8GB Ram/3GB GDDR5 Radeon R9 200 GPU).

Before I had Steelseries 650 but it came with broken sound card from factory so I had to change them but with those I had no problem playing/listening music. And before that I had some HyperX but those were really bad quality, but still, no similar problems. Sometimes I miss some windows sounds, like clicking the volume bar many times or starting a faceit game (no start sound), but just from time to time.... Youtube runs good when I'm only on Chrome tho and no CSGO open.
It is razer so I wouldn't be surprised if it's something wrong with the headphones. Do you have Synapse installed?>
 
May 28, 2020
4
0
10
0
I've recently upgraded the OS from Windows 7 to Windows 10 and seems like its quite a improvment. I still have some sutterings from time to time when I overload the rigg but except that, sounds better than on the previous windows, problem not solved but still slighty improved.
 

ASK THE COMMUNITY