[SOLVED] Razer Naga Hex v2 - Not Detected by Synapse

ThundyUK

Prominent
Nov 23, 2019
11
0
510
0
Hi all,

I'm having some problems with my Hex v2. The mouse works, but for some reason Synapse will no longer "see" it so I can't access the liftoff calibration, the custom sensitivity options, the programmable macros... you get the idea :)

I've done everything I can think of but it's still not having it so I'm just after some more ideas if anyone has any?

The things I've tried

Delete Synapse (automatically)
Manually remove Synapse folders etc from both prog files and appdata
Uninstalled drivers via Dev Manager
Reset the mouse (hold 3x buttons in whilst unplugging and re-plugging it in)
Removed and install .Net Framework again
Reinstalled all Synapse software
Tried every USB port

My OS Is Win 7 64bit

I mean there's only so much I can think of so I'm a little lost now, and it's JUST run out of warranty last month as well typically so hopefully it's not knackered it wasn't cheap.

Any tips would be greatly appreciated :)

Thanks
 
Last edited:
Dec 25, 2019
1
0
10
1
mate unless you get the kraken tounament edition it does not detect on there own .... but razer will send you a code, when you register your head phones .. so go do that then check your emails .. the code they send you activates the Synapse will work
 

ThundyUK

Prominent
Nov 23, 2019
11
0
510
0
Well, I've tried everything and Razer have agreed to send me a new one. Out of warranty too nice of them :)
I doubt it will fix it so I guess a total Windows reinstall is on the cards.
Thanks anyway.....
 
Dec 25, 2019
1
0
10
1
mate unless you get the kraken tounament edition it does not detect on there own .... but razer will send you a code, when you register your head phones .. so go do that then check your emails .. the code they send you activates the Synapse will work
 

ASK THE COMMUNITY

TRENDING THREADS