Question Razer Naga Pro freezes on wireless mode, but not wired.

Sep 4, 2022
7
0
10
0
I have tried to find a solution to this issue but I cannot seem to find anything that works. The mouse will freeze up randomly for about a second or two. This usually happens in games, but also happens when I am in the browser occasionally. This issue ONLY happens when wireless (Bluetooth and 2.4 connections)
here are my build specs if this helps anything Processor:
AMD Ryzen 7 5800X
Motherboard:
GIGABYTE B550 AORUS PRO AC
Memory:
32 GB [16 GB x2] DDR4-3200 Corsair vengeance
Video Card:
EVGA FTW3 Ultra RTX 3070
Power Supply:
1000w - EVGA G3 Gold+
Processor Cooling:
Corsair h100i - 240 rad
Primary drive:
2 TB Samsung 970 EVO Plus - m.2 SSD
Primary Hard Drive:
500 GB Samsung 860 EVO - SATA SSD
Secondary Hard Drive:
1 TB Samsung 860 EVO - SATA SSD

I have tried
1: messing with power management in device manager
2: Uninstalling and reinstalling synapse (happens with synapse closed)
3: uninstalling all drivers for usb hubs and mouse and letting windows reinstall them
4: this issue does NOT happen when I use the mouse with my laptop, only my desktop
5: I have moved the usb receiver to EVERY USB port on my PC
6: Razer Support was extremely unhelpful
7: I have even done a clean reinstall of windows because I tried to see if I simply had a corrupt driver somewhere

I know I’ve tried more that I can’t think of now but nothing seems to work, like I said this ONLY happens on wireless mode and ONLY on my desktop. It’s driving me insane as I really do like this mouse.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

What BIOS version are you on for your motherboard? Out of curiosity. since the laptop is closer proximity to the mouse, how far off is the case/build from the mouse? Might want to see if reinstalling your motherboard's wireless adapter's drivers helps.

done a clean reinstall of windows
Where did you source the installer from?
 
Last edited:
i have one razer mice aswell, when wifi dongle was on left side of mouse, mouse worked pretty fine, when dongle was on right side of mouse, my hand was blocking signal and mouse acted strangely
switched to logitech and no issues yet
 
Sep 4, 2022
7
0
10
0
Welcome to the forums, newcomer!

What BISO version are you on for your motherboard? Out of curiosity. since the laptop is closer proximity to the mouse, how far off is the case/build from the mouse? Might want to see if reinstalling your motherboard's wireless adapter's drivers helps.

done a clean reinstall of windows
Where did you source the installer from?
I am
Welcome to the forums, newcomer!

What BISO version are you on for your motherboard? Out of curiosity. since the laptop is closer proximity to the mouse, how far off is the case/build from the mouse? Might want to see if reinstalling your motherboard's wireless adapter's drivers helps.

done a clean reinstall of windows
Where did you source the installer from?
I am running BIOS F15c
My pc is on a shelf to my right. I have an L desk with a shelf for my pc. It’s pretty close to the mouse.
I don’t think I’ve tried the wireless adapter drivers, I’m not super familiar with it all
 
Sep 4, 2022
7
0
10
0
i have one razer mice aswell, when wifi dongle was on left side of mouse, mouse worked pretty fine, when dongle was on right side of mouse, my hand was blocking signal and mouse acted strangely
switched to logitech and no issues yet
You may be on to something
i have one razer mice aswell, when wifi dongle was on left side of mouse, mouse worked pretty fine, when dongle was on right side of mouse, my hand was blocking signal and mouse acted strangely
switched to logitech and no issues yet
ive tried utilizing the pass through usb on my keyboard as well. Still the same result, even though it’s essentially closer to my mouse than even with my laptop. I’ve tried turning WiFi and Bluetooth off in case it was interfering, nothing. Simply stumped now.

I don’t intend to buy anymore razer peripherals, I love the designs but the issues I have are a nightmare. To use my huntsman V2 Analog (their flagship keyboard) I had to disable one of the drivers in device management otherwise I end up with repeating keys constantly.
It’s too expensive to justify swapping everything yet, but I will most likely go to Logitech next.
 
Sep 5, 2022
3
0
10
0
Make sure the mouse is running the most current firmware. I had issues with a razer mouse and updating the firmware fixed everything.
 
Sep 4, 2022
7
0
10
0
Yea, I’ve tried that when i tried to reach out to razer support. I used their tool to check and manually checked through device manager.
 
Sep 4, 2022
7
0
10
0
I have tried to find a solution to this issue but I cannot seem to find anything that works. The mouse will freeze up randomly for about a second or two. This usually happens in games, but also happens when I am in the browser occasionally. This issue ONLY happens when wireless (Bluetooth and 2.4 connections)
here are my build specs if this helps anything Processor:
AMD Ryzen 7 5800X
Motherboard:
GIGABYTE B550 AORUS PRO AC
Memory:
32 GB [16 GB x2] DDR4-3200 Corsair vengeance
Video Card:
EVGA FTW3 Ultra RTX 3070
Power Supply:
1000w - EVGA G3 Gold+
Processor Cooling:
Corsair h100i - 240 rad
Primary drive:
2 TB Samsung 970 EVO Plus - m.2 SSD
Primary Hard Drive:
500 GB Samsung 860 EVO - SATA SSD
Secondary Hard Drive:
1 TB Samsung 860 EVO - SATA SSD

I have tried
1: messing with power management in device manager
2: Uninstalling and reinstalling synapse (happens with synapse closed)
3: uninstalling all drivers for usb hubs and mouse and letting windows reinstall them
4: this issue does NOT happen when I use the mouse with my laptop, only my desktop
5: I have moved the usb receiver to EVERY USB port on my PC
6: Razer Support was extremely unhelpful
7: I have even done a clean reinstall of windows because I tried to see if I simply had a corrupt driver somewhere

I know I’ve tried more that I can’t think of now but nothing seems to work, like I said this ONLY happens on wireless mode and ONLY on my desktop. It’s driving me insane as I really do like this mouse.
An update on this situation. The issue only seems to be worse now. It used to have not disconnect while gaming and very very rarely anywhere else. Now it seems to do it on my desktop.
A new thing I have tried is uninstalling each device in device manager. Uninstalling synapse 3. And then unplugging all of my peripherals. I then used CCleaner to clear my registry and essentially get rid of everything razer on my pc.
I then connected a cheapo mouse and restarted the pc, reinstalled synapse, and plugged only my mouse in. I let synapse do it’s thing and then tried it again. Exact same issue

again, this only happens when it is in wireless mode. And it is the ONLY device that disconnects randomly. It also does not give a disconnected sound effect through windows. It just seems to swap to the default razer lighting (spectrum cycle instead of static red) and then freeze up.

I have put almost every software other than Microsoft applications in sleep/disabled. It doesn’t seem to be a pc issue.

could I simply just have a dying mouse? Or just a dying 2.4 adapter?
 
Oct 5, 2022
1
0
10
0
I thought I was the only one having this issue! I haven’t found a fix yet, but I’m with the school of thought that this is a mouse and/or dongle issue rather than a software/firmware/drivers/etc. issue. It’s just strange that it works perfectly fine wired… which tells us it’s most likely not an issue with the mouse’s laser.

It’s looking grim, but if I find a solution I’ll be sure to post it here!
 
Sep 4, 2022
7
0
10
0
I thought I was the only one having this issue! I haven’t found a fix yet, but I’m with the school of thought that this is a mouse and/or dongle issue rather than a software/firmware/drivers/etc. issue. It’s just strange that it works perfectly fine wired… which tells us it’s most likely not an issue with the mouse’s laser.

It’s looking grim, but if I find a solution I’ll be sure to post it here!
I’m willing to bet it could be the dongle. My only real confusion is how it will still work perfectly on my laptop but not my desktop. At this point I’ve basically given up as I’m totally out of ideas now. I just use it wired now.
 
Probably nothing like your problem but I had an issue with my keyboard freezing/disconnecting and reconnecting. It turned out to be the USB hub and every time my Apple Watch received a notification. I only fixed it by changing the USB hub.
 
Sep 4, 2022
7
0
10
0
Probably nothing like your problem but I had an issue with my keyboard freezing/disconnecting and reconnecting. It turned out to be the USB hub and every time my Apple Watch received a notification. I only fixed it by changing the USB hub.
I’m not sure, I have it plugged directly into the motherboard (I’ve also tried the pass through on my keyboard) for whatever reason it’s the only device that seems to do it. I’ve tried it being the only thing plugged in and moved it to every USB port on the board. I also even tried a female to male usb extender to have the dongle right next to my hand. Same issue every time.
I’ve even taken isopropyl to as much as I could in case it was simply a dirty laser. Nothing
 

ASK THE COMMUNITY

TRENDING THREADS